Project

General

Profile

Bug #49014

OSD service specifications ignore "rotational: 0"

Added by Lukas Stockner almost 2 years ago. Updated almost 2 years ago.

Status:
Resolved
Priority:
Normal
Assignee:
-
Category:
orchestrator
Target version:
-
% Done:

0%

Source:
Tags:
Backport:
Regression:
Yes
Severity:
3 - minor
Reviewed:
ceph-qa-suite:
Pull request ID:
Crash signature (v1):
Crash signature (v2):

Description

When applying an OSD service specification like

service_type: osd
service_id: hdd
placement:
  label: hdd-osd
encrypted: true
data_devices:
  rotational: 1
db_devices:
  rotational: 0

the OSDs are deployed without any DB devices and ceph orch ls --export shows that the db_devices section has not been applied:
service_type: osd
service_id: hdd
service_name: osd.hdd
placement:
  label: hdd-osd
spec:
  data_devices:
    rotational: 1
  encrypted: true
  filter_logic: AND
  objectstore: bluestore

This is caused by the rotational filter, moving it to other sections causes those to disappear.

History

#1 Updated by Lukas Stockner almost 2 years ago

Fix PR is 39083.

#2 Updated by Sebastian Wagner almost 2 years ago

  • Status changed from New to Pending Backport
  • Pull request ID set to 39083

#3 Updated by Sebastian Wagner almost 2 years ago

  • Status changed from Pending Backport to Resolved

Also available in: Atom PDF