Project

General

Profile

Bug #48923

pacific: pybind: revert removal of ceph_volume_client library

Added by Ramana Raja about 1 month ago. Updated about 1 month ago.

Status:
Resolved
Priority:
Normal
Assignee:
-
Category:
-
Target version:
% Done:

0%

Source:
Community (dev)
Tags:
Backport:
Regression:
No
Severity:
2 - major
Reviewed:
Affected Versions:
ceph-qa-suite:
Component(FS):
VolumeClient
Labels (FS):
Manila
Pull request ID:
Crash signature:

Description

The primary consumers of the ceph_volume_client_library are OpenStack manila's CephFS drivers. The drivers have not yet transitioned to using mgr/volumes. Considering that the drivers have been in production for a few years and the drivers are in production, it's safer to remove the ceph_volume_client library once the manila drivers have transitioned to mgr/volumes.

History

#1 Updated by Ramana Raja about 1 month ago

  • Subject changed from pybind: revert removal of ceph_volume_client library to pacific: pybind: revert removal of ceph_volume_client library
  • Status changed from New to In Progress
  • Target version set to v16.0.0
  • Source set to Community (dev)

#2 Updated by Ramana Raja about 1 month ago

This is not a backport. This revert is targeted for pacific. Please see, https://github.com/ceph/ceph/pull/38960#issuecomment-763908706
CephFS PTL, Patrick Donnelly, suggested that we revert the library for pacific release alone. This decision was taken with inputs from the manila community developers due to the reason mentioned in the description.

#3 Updated by Kotresh Hiremath Ravishankar about 1 month ago

  • Pull request ID set to 39014

#4 Updated by Ramana Raja about 1 month ago

  • Status changed from In Progress to Resolved

#5 Updated by Nathan Cutler about 1 month ago

  • Target version changed from v16.0.0 to v16.1.0

Also available in: Atom PDF