Project

General

Profile

Bug #48893

Ceph-osd refuses to bind on an IP on the local loopback lo

Added by Thomas Goirand 5 months ago. Updated 2 months ago.

Status:
Resolved
Priority:
Normal
Assignee:
-
Category:
common
Target version:
-
% Done:

0%

Source:
Community (dev)
Tags:
Backport:
nautilus, octopus
Regression:
No
Severity:
3 - minor
Reviewed:
Affected Versions:
ceph-qa-suite:
Pull request ID:
Crash signature (v1):
Crash signature (v2):

Description

Hi,

Starting with Nautilus, and unless the IP is specified explicitly in ceph.conf, ceph-osd only searches for IPs that aren't on the local loopback. This is problematic for anyone doing a bgp-to-the-host deployment, where this is precisely what's configured.

The issue seems to be located at:

https://github.com/ceph/ceph/blob/master/src/common/ipaddr.cc#L63


Related issues

Related to Ceph - Bug #43417: Since the local loopback address is set to a virtual IP,OSD can't restart . Resolved
Related to Ceph - Bug #49938: daemons bind to loopback iface Resolved
Related to RADOS - Bug #50688: Ceph can't be deployed using cephadm on nodes with /32 ip addresses Duplicate
Copied to Ceph - Backport #48903: nautilus: Ceph-osd refuses to bind on an IP on the local loopback lo Resolved
Copied to Ceph - Backport #48904: octopus: Ceph-osd refuses to bind on an IP on the local loopback lo Resolved
Copied to RADOS - Bug #50012: Ceph-osd refuses to bind on an IP on the local loopback lo (again) Fix Under Review
Copied to Ceph - Bug #50456: Ceph-osd refuses to bind on an IP on the local loopback lo Pending Backport

History

#1 Updated by Kefu Chai 5 months ago

  • Status changed from New to Fix Under Review
  • Backport set to nautilus, octopus
  • Pull request ID set to 38925

#2 Updated by Kefu Chai 5 months ago

  • Related to Bug #43417: Since the local loopback address is set to a virtual IP,OSD can't restart . added

#3 Updated by Neha Ojha 5 months ago

  • Status changed from Fix Under Review to Pending Backport

#4 Updated by Backport Bot 5 months ago

  • Copied to Backport #48903: nautilus: Ceph-osd refuses to bind on an IP on the local loopback lo added

#5 Updated by Backport Bot 5 months ago

  • Copied to Backport #48904: octopus: Ceph-osd refuses to bind on an IP on the local loopback lo added

#6 Updated by Loïc Dachary 3 months ago

  • Status changed from Pending Backport to Resolved

While running with --resolve-parent, the script "backport-create-issue" noticed that all backports of this issue are in status "Resolved" or "Rejected".

#8 Updated by Kefu Chai 3 months ago

  • Copied to Bug #50012: Ceph-osd refuses to bind on an IP on the local loopback lo (again) added

#9 Updated by Nathan Cutler 3 months ago

  • Related to Bug #49938: daemons bind to loopback iface added

#10 Updated by Kefu Chai about 2 months ago

  • Copied to Bug #50456: Ceph-osd refuses to bind on an IP on the local loopback lo added

#11 Updated by Sebastian Wagner 14 days ago

  • Related to Bug #50688: Ceph can't be deployed using cephadm on nodes with /32 ip addresses added

Also available in: Atom PDF