Project

General

Profile

Bug #48830

pacific: qa: :ERROR: test_idempotency

Added by Patrick Donnelly 11 months ago. Updated 9 months ago.

Status:
Resolved
Priority:
High
Category:
-
Target version:
% Done:

0%

Source:
Q/A
Tags:
Backport:
pacific,octopus,nautilus
Regression:
No
Severity:
3 - minor
Reviewed:
Affected Versions:
ceph-qa-suite:
Component(FS):
mgr/volumes
Labels (FS):
qa, qa-failure
Pull request ID:
Crash signature (v1):
Crash signature (v2):

Description

2021-01-10T22:28:04.504 INFO:tasks.cephfs_test_runner:======================================================================
2021-01-10T22:28:04.504 INFO:tasks.cephfs_test_runner:ERROR: test_idempotency (tasks.cephfs.test_volume_client.TestVolumeClient)
2021-01-10T22:28:04.504 INFO:tasks.cephfs_test_runner:----------------------------------------------------------------------
2021-01-10T22:28:04.505 INFO:tasks.cephfs_test_runner:Traceback (most recent call last):
2021-01-10T22:28:04.505 INFO:tasks.cephfs_test_runner:  File "/home/teuthworker/src/git.ceph.com_ceph-c_wip-pdonnell-testing-20210110.050947/qa/tasks/cephfs/test_volume_client.py", line 349, in test_idempotency
2021-01-10T22:28:04.505 INFO:tasks.cephfs_test_runner:    guest_entity=guest_entity
2021-01-10T22:28:04.506 INFO:tasks.cephfs_test_runner:  File "/home/teuthworker/src/git.ceph.com_ceph-c_wip-pdonnell-testing-20210110.050947/qa/tasks/cephfs/test_volume_client.py", line 41, in _volume_client_python
2021-01-10T22:28:04.506 INFO:tasks.cephfs_test_runner:    vol_prefix=vol_prefix, ns_prefix=ns_prefix))
2021-01-10T22:28:04.506 INFO:tasks.cephfs_test_runner:  File "/home/teuthworker/src/git.ceph.com_ceph-c_wip-pdonnell-testing-20210110.050947/qa/tasks/cephfs/mount.py", line 667, in run_python
2021-01-10T22:28:04.506 INFO:tasks.cephfs_test_runner:    p.wait()
2021-01-10T22:28:04.507 INFO:tasks.cephfs_test_runner:  File "/home/teuthworker/src/git.ceph.com_git_teuthology_master/teuthology/orchestra/run.py", line 161, in wait
2021-01-10T22:28:04.507 INFO:tasks.cephfs_test_runner:    self._raise_for_status()
2021-01-10T22:28:04.507 INFO:tasks.cephfs_test_runner:  File "/home/teuthworker/src/git.ceph.com_git_teuthology_master/teuthology/orchestra/run.py", line 183, in _raise_for_status
2021-01-10T22:28:04.508 INFO:tasks.cephfs_test_runner:    node=self.hostname, label=self.label
2021-01-10T22:28:04.508 INFO:tasks.cephfs_test_runner:teuthology.exceptions.CommandFailedError: Command failed on smithi153 with status 1: 'sudo adjust-ulimits daemon-helper kill python3 -c \'\nfrom __future__ import print_function\nfrom ceph_volume_client import CephFSVolumeClient, VolumePath\nfrom sys import version_info as sys_version_info\nfrom rados import OSError as rados_OSError\nimport logging\nlog = logging.getLogger("ceph_volume_client")\nlog.addHandler(logging.StreamHandler())\nlog.setLevel(logging.DEBUG)\nvc = CephFSVolumeClient("manila", "/etc/ceph/ceph.conf", "ceph", None, None)\nvc.connect()\n\nvp = VolumePath("grpid", "volid")\nvc.create_volume(vp, 10)\nvc.create_volume(vp, 10)\nvc.authorize(vp, "guest")\nvc.authorize(vp, "guest")\nvc.deauthorize(vp, "guest")\nvc.deauthorize(vp, "guest")\nvc.delete_volume(vp)\nvc.delete_volume(vp)\nvc.purge_volume(vp)\nvc.purge_volume(vp)\n\nvc.create_volume(vp, 10, data_isolated=True)\nvc.create_volume(vp, 10, data_isolated=True)\nvc.authorize(vp, "guest")\nvc.authorize(vp, "guest")\nvc.deauthorize(vp, "guest")\nvc.deauthorize(vp, "guest")\nvc.evict("guest")\nvc.evict("guest")\nvc.delete_volume(vp, data_isolated=True)\nvc.delete_volume(vp, data_isolated=True)\nvc.purge_volume(vp, data_isolated=True)\nvc.purge_volume(vp, data_isolated=True)\n\nvc.create_volume(vp, 10, namespace_isolated=False)\nvc.create_volume(vp, 10, namespace_isolated=False)\nvc.authorize(vp, "guest")\nvc.authorize(vp, "guest")\nvc.deauthorize(vp, "guest")\nvc.deauthorize(vp, "guest")\nvc.evict("guest")\nvc.evict("guest")\nvc.delete_volume(vp)\nvc.delete_volume(vp)\nvc.purge_volume(vp)\nvc.purge_volume(vp)\n\nvc.disconnect()\n        \''

From: /ceph/teuthology-archive/pdonnell-2021-01-10_18:07:36-fs-wip-pdonnell-testing-20210110.050947-distro-basic-smithi/5773901/teuthology.log


Related issues

Copied to CephFS - Backport #49160: nautilus: qa: :ERROR: test_idempotency Resolved
Copied to CephFS - Backport #49230: octopus: qa: :ERROR: test_idempotency Resolved
Copied to CephFS - Backport #49496: pacific: pacific: qa: :ERROR: test_idempotency Resolved

History

#1 Updated by Patrick Donnelly 11 months ago

  • Target version changed from v16.0.0 to v17.0.0
  • Backport changed from octopus,nautilus to pacific,octopus,nautilus

#2 Updated by Kotresh Hiremath Ravishankar 11 months ago

  • Status changed from New to In Progress

The issue is no longer applicable to master as the test is removed as part of removing ceph_volume_client [1]

[1] https://github.com/ceph/ceph/pull/38846

#3 Updated by Ramana Raja 10 months ago

  • Subject changed from qa: :ERROR: test_idempotency to pacific: qa: :ERROR: test_idempotency
  • Backport changed from pacific,octopus,nautilus to octopus,nautilus

#4 Updated by Kotresh Hiremath Ravishankar 10 months ago

  • Status changed from In Progress to Fix Under Review
  • Pull request ID set to 39038

#5 Updated by Kotresh Hiremath Ravishankar 10 months ago

#6 Updated by Kotresh Hiremath Ravishankar 10 months ago

#7 Updated by Kotresh Hiremath Ravishankar 10 months ago

  • Status changed from Fix Under Review to Pending Backport

#8 Updated by Nathan Cutler 9 months ago

  • Backport changed from octopus,nautilus to pacific,octopus,nautilus

#9 Updated by Backport Bot 9 months ago

  • Copied to Backport #49496: pacific: pacific: qa: :ERROR: test_idempotency added

#10 Updated by Nathan Cutler 9 months ago

  • Status changed from Pending Backport to Resolved

While running with --resolve-parent, the script "backport-create-issue" noticed that all backports of this issue are in status "Resolved" or "Rejected".

Also available in: Atom PDF