Project

General

Profile

Bug #48826

cephadm: does not tolerate 15.2.4 upgrade state

Added by Sage Weil 5 months ago. Updated 5 months ago.

Status:
Won't Fix
Priority:
High
Assignee:
-
Category:
-
Target version:
-
% Done:

0%

Source:
Tags:
Backport:
Regression:
Yes
Severity:
3 - minor
Reviewed:
Affected Versions:
ceph-qa-suite:
Pull request ID:
Crash signature (v1):
Crash signature (v2):

Description

2021-01-11T15:32:44.348+0000 7f37a948e700 10 ceph_store_get upgrade_state found: {"target_name": "docker.io/ceph/ceph:v15.2.5", "progress_id": "36280687-2d0c-41d9-8d76-58ead41246db", "target_id": "4405f6339e35a3525cc53bff39f0ed6e081991bd445fb57b5ffded6a7efac1b6", "repo_digest": "ceph/ceph@sha256:939a46c06b334e094901560c8346de33c00309e3e3968a2db240eb4897c6a508", "target_version": "ceph version 15.2.5 (2c93eff00150f0cc5f106a559557a58d3d7b6f1f) octopus (stable)", "error": null, "paused": false}
2021-01-11T15:32:44.348+0000 7f37a948e700 -1 mgr load Failed to construct class in 'cephadm'
2021-01-11T15:32:44.348+0000 7f37a948e700 -1 mgr load Traceback (most recent call last):
  File "/usr/share/ceph/mgr/cephadm/module.py", line 312, in __init__
    self.upgrade = CephadmUpgrade(self)
  File "/usr/share/ceph/mgr/cephadm/upgrade.py", line 59, in __init__
    self.upgrade_state: Optional[UpgradeState] = UpgradeState.from_json(json.loads(t))
  File "/usr/share/ceph/mgr/cephadm/upgrade.py", line 50, in from_json
    return cls(**data)
TypeError: __init__() got an unexpected keyword argument 'repo_digest'

History

#1 Updated by Sebastian Wagner 5 months ago

  • Project changed from mgr to Orchestrator

#2 Updated by Sebastian Wagner 5 months ago

looks like a downgrade to me.

https://github.com/ceph/ceph/commit/36dc59987136f921c24932b2e0a2530ce3a22152 was merged in August and landed in 15.2.5
https://github.com/ceph/ceph/commit/eb7757f88569a9adb8bccbaf706afe1c878afc60 was merged in September and landed in 15.2.8

For now, the workaround is to call https://docs.ceph.com/en/latest/cephadm/upgrade/#canceling-an-upgrade

#3 Updated by Dan Mick 5 months ago

What was the job config?

#4 Updated by Dan Mick 5 months ago

We're not trying to support downgrade at all, right?

#5 Updated by Sebastian Wagner 5 months ago

If you're in an intermediate upgrade step and one MGR is already upgraded and the other one is still running with the old version. And then you're doing a failover from the new MGR to the old MGR, you're somewhat doing a downgrade.

#6 Updated by Sage Weil 5 months ago

  • Status changed from New to Won't Fix

I first tried to upgraded to .8, hit a different error (the ceph-volume --filter-batch thing), then switched to .5 instead.. that's why this happened. Closing!

#7 Updated by Sebastian Wagner 5 months ago

if you happen to have a mgr failover from .8 to .5, users might also hit this bug.

Also available in: Atom PDF