Project

General

Profile

Bug #48695

cephadm: upgrade should not get blocked, on intermediate UPGRADE_FAILED_PULL

Added by Sebastian Wagner 2 months ago. Updated 7 days ago.

Status:
Closed
Priority:
Normal
Assignee:
Category:
cephadm
Target version:
-
% Done:

0%

Source:
Tags:
Backport:
Regression:
No
Severity:
3 - minor
Reviewed:
Affected Versions:
ceph-qa-suite:
Pull request ID:
Crash signature:

Description

https://pulpito.ceph.com/swagner-2020-12-18_12:41:30-rados:cephadm-wip-swagner-testing-2020-12-16-0203-distro-basic-smithi/

After:

(mgr.34517) 27 : cephadm [INF] Upgrade: Pulling quay.ceph.io/ceph-ci/ceph:e6ce86de47ecdf0df5510dcc6a14e5bca492f14a on smithi101
(mgr.34517) 28 : cephadm [ERR] Upgrade: Paused due to UPGRADE_FAILED_PULL: Upgrade: failed to pull target image
(mgr.34517) 29 : cluster [DBG] pgmap v12: 1 pgs: 1 active+clean; 0 B data, 3.7 MiB used, 707 GiB / 715 GiB avail
(mon.0) 626 : cluster [WRN] Health check failed: Upgrade: failed to pull target image (UPGRADE_FAILED_PULL)

the image was never pulled again and the upgrade test failed.


Related issues

Related to Orchestrator - Bug #46204: cephadm upgrade test: fail if upgrade status is set to error New

History

#1 Updated by Sebastian Wagner 2 months ago

  • Related to Bug #46204: cephadm upgrade test: fail if upgrade status is set to error added

#2 Updated by Juan Miguel Olmo Martínez 10 days ago

  • Assignee set to Adam King

#4 Updated by Adam King 7 days ago

  • Status changed from New to Closed

The problem only is an issue when upgrading from older versions (that don't include https://github.com/ceph/ceph/commit/f3e770f3541c716b4f568cf73255f25243c655e5). Newer versions properly use the ignorelist and retry the pulls (https://pastebin.com/raw/Dx4qjbwg ignore Bs and podman error printout, that was for testing)

Also available in: Atom PDF