Project

General

Profile

Bug #48684

the logging config within cephadm binary defaults to sys.stderr

Added by Paul Cuzner about 1 month ago. Updated about 1 month ago.

Status:
Won't Fix
Priority:
Normal
Assignee:
Category:
cephadm (binary)
Target version:
% Done:

0%

Source:
Tags:
Backport:
Regression:
No
Severity:
3 - minor
Reviewed:
Affected Versions:
ceph-qa-suite:
Pull request ID:
Crash signature:

Description

The streamhandler defaults to sys.stderr which means tasks like check_host returns passed and failed tests in same list back to the caller.

The console handler should include
'stream': 'ext://sys.stdout'

so when the output is returned to the caller stdout and stderr variables are populated correctly.

History

#1 Updated by Paul Cuzner about 1 month ago

  • Status changed from New to Won't Fix

adding the change to the stream fixes tasks like host add
[ceph: root@maint-1 /]# ceph orch host add maint-4
Error EINVAL: New host maint-4 (maint-4) failed check: ["ERROR: Unable to locate any of ['podman', 'docker']", 'lvcreate binary does not appear to be installed', 'hostname "maint-4.storage.lab" does not match expected hostname "maint-4"']

But podman invocations now fail since /bin/podman stdout is now embedded in the output!

Less impactful to fix add host!

Closing bug

Also available in: Atom PDF