Project

General

Profile

Bug #48616

mgr/dashboard: Root dashboard url with url_prefix requires a forward slash at the end

Added by Matt Wilder about 2 years ago. Updated 7 months ago.

Status:
Closed
Priority:
Normal
Assignee:
-
Category:
UX
Target version:
-
% Done:

0%

Source:
Tags:
Backport:
nautilus, octopus
Regression:
No
Severity:
3 - minor
Reviewed:
ceph-qa-suite:
Pull request ID:
Crash signature (v1):
Crash signature (v2):

Description

If you set a URL prefix for the Ceph dashboard, the default login page will not load unless the requested URL contains a forward slash at the end.

Environment

  • ceph version string: Confirmed issue exists with 15.2.4, test builds of 15.2.7 and 16.0.0
  • Platform (OS/distro/release): All platforms affected, but tested on Linux
  • Cluster details (nodes, monitors, OSDs): Tested with 3 node rook based cluster in Kubernetes and a local devel cluster using make vstart
  • Browser used (e.g.: Version 86.0.4240.198 (Official Build) (64-bit)): Tested with Chrome 87.0.4280.88 (Official Build) (x86_64)

How reproducible

1) Set a dashboard URL prefix:

$ ceph config set mgr mgr/dashboard/url_prefix /ceph

2) Visit dashboard url without a forward slash at the end:

https://localhost:41409/ceph

Actual results

Instead of the login page, an 404 error message in json is displayed:

{"status": "404 Not Found", "detail": "The path '/ceph' was not found.", "request_id": "da796597-e50e-4994-987b-c19c34934623"}

However, if you add a forward slash to the end, the login page loads correctly.

https://localhost:41409/ceph/

Expected results

The login page should be shown regardless of the presence of a forward slash at the end of the URL.

Additional info

History

#1 Updated by Ernesto Puerta about 2 years ago

  • Status changed from New to Triaged
  • Assignee set to Avan Thakkar
  • Backport set to nautilus, octopus

#2 Updated by Avan Thakkar almost 2 years ago

  • Assignee deleted (Avan Thakkar)

#3 Updated by Ernesto Puerta almost 2 years ago

  • Project changed from mgr to Dashboard
  • Category changed from 152 to UX

#4 Updated by Sarthak Gupta 7 months ago

This seems to be working (for me locally).

#5 Updated by Sarthak Gupta 7 months ago

  • Status changed from Triaged to Closed

Also available in: Atom PDF