Project

General

Profile

Bug #48441

mgr/dashboard: mgr-dashboard-frontend-unittests (Failed)

Added by Ernesto Puerta about 2 months ago. Updated about 2 months ago.

Status:
Resolved
Priority:
Immediate
Category:
dashboard/iscsi
Target version:
% Done:

0%

Source:
Community (dev)
Tags:
Backport:
Regression:
No
Severity:
1 - critical
Reviewed:
Affected Versions:
ceph-qa-suite:
Pull request ID:
Crash signature:

Description

make check is failing at mgr-dashboard-frontend-unittests

Test suite failed to run

    src/app/ceph/block/iscsi-target-form/iscsi-target-form.component.spec.ts:7:30 - error TS2307: Cannot find module 'app/shared/components/select/select-option.model' or its corresponding type declarations.

    7 import { SelectOption } from 'app/shared/components/select/select-option.model';
                                   ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~

.
  ● Test suite failed to run

    src/app/ceph/block/iscsi-target-form/iscsi-target-form.component.spec.ts:7:30 - error TS2307: Cannot find module 'app/shared/components/select/select-option.model' or its corresponding type declarations.

    7 import { SelectOption } from 'app/shared/components/select/select-option.model';
                                   ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~

.
  ● Test suite failed to run

    src/app/ceph/block/iscsi-target-form/iscsi-target-form.component.spec.ts:7:30 - error TS2307: Cannot find module 'app/shared/components/select/select-option.model' or its corresponding type declarations.

    7 import { SelectOption } from 'app/shared/components/select/select-option.model';
                                   ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~

.
  ● Test suite failed to run

    src/app/ceph/block/iscsi-target-form/iscsi-target-form.component.spec.ts:7:30 - error TS2307: Cannot find module 'app/shared/components/select/select-option.model' or its corresponding type declarations.

    7 import { SelectOption } from 'app/shared/components/select/select-option.model';
                                   ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~

.
  ● Test suite failed to run

    src/app/ceph/block/iscsi-target-form/iscsi-target-form.component.spec.ts:7:30 - error TS2307: Cannot find module 'app/shared/components/select/select-option.model' or its corresponding type declarations.

    7 import { SelectOption } from 'app/shared/components/select/select-option.model';
                                   ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~

.
  ● Test suite failed to run

    src/app/ceph/block/iscsi-target-form/iscsi-target-form.component.spec.ts:7:30 - error TS2307: Cannot find module 'app/shared/components/select/select-option.model' or its corresponding type declarations.

    7 import { SelectOption } from 'app/shared/components/select/select-option.model';
                                   ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~

.
  ● Test suite failed to run

    src/app/ceph/block/iscsi-target-form/iscsi-target-form.component.spec.ts:7:30 - error TS2307: Cannot find module 'app/shared/components/select/select-option.model' or its corresponding type declarations.

    7 import { SelectOption } from 'app/shared/components/select/select-option.model';

It's likely that this error was introduced by this PR: https://github.com/ceph/ceph/pull/37198 :
  • How was it possible for that to pass CI? Because last make check run is from Oct 22, so later changes merged would have caused this to break.
  • Lesson learnt: on stale PR's (more than a week old) we should always retrigger checks prior to merging.
  • Additionally, a post-merge build could help quickly identify breakages.

Related issues

Blocked by mgr - Bug #47445: mgr/dashboard: Its currently not possible to manage iSCSI Initiator's disks after removing from group Pending Backport

History

#1 Updated by Ernesto Puerta about 2 months ago

  • Description updated (diff)

#2 Updated by Ernesto Puerta about 2 months ago

  • Assignee set to Ernesto Puerta
  • Pull request ID set to 38409

#3 Updated by Ernesto Puerta about 2 months ago

  • Status changed from New to Fix Under Review

#4 Updated by Ernesto Puerta about 2 months ago

  • Status changed from Fix Under Review to Resolved

#5 Updated by Ernesto Puerta about 2 months ago

  • Blocked by Bug #47445: mgr/dashboard: Its currently not possible to manage iSCSI Initiator's disks after removing from group added

Also available in: Atom PDF