Project

General

Profile

Bug #48290

mgr/dashboard: deletion of host doesn't reflect the dashboard

Added by Avan Thakkar about 2 months ago. Updated about 1 month ago.

Status:
Won't Fix
Priority:
Normal
Assignee:
Category:
-
Target version:
-
% Done:

0%

Source:
Tags:
Backport:
Regression:
No
Severity:
3 - minor
Reviewed:
Affected Versions:
ceph-qa-suite:
Pull request ID:
Crash signature:

Description

On removing hosts the list is not getting updated (for both CLI & UI). Just the Edit/Delete actions gets disabled for the deleted hosts.

Screenshot from 2020-11-19 12-57-20.png View (147 KB) Avan Thakkar, 11/19/2020 12:25 PM

Screenshot from 2020-11-26 17-01-37.png View - Cluster->Monitors ceph-node-02 present (59.5 KB) Avan Thakkar, 11/26/2020 11:33 AM

Screenshot from 2020-11-26 17-01-54.png View - Cluster->Services->mon ceph-node-02 absent (82.7 KB) Avan Thakkar, 11/26/2020 11:33 AM

Screenshot from 2020-11-26 17-01-27.png View - Deleted ceph-node-02 host (46.8 KB) Avan Thakkar, 11/26/2020 11:33 AM


Related issues

Related to Orchestrator - Feature #47782: ceph orch host rm <host> is not stopping the services deployed in the respective removed hosts New

History

#1 Updated by Avan Thakkar about 2 months ago

  • Pull request ID set to 38186

#2 Updated by Kiefer Chang about 2 months ago

  • Related to Feature #47782: ceph orch host rm <host> is not stopping the services deployed in the respective removed hosts added

#3 Updated by Kiefer Chang about 2 months ago

cephadm doesn't tear down the services on a removed host yet. Please see #47782.
I would suggest we keep revealing those services on the host list to let the admin know there are still some services.

#4 Updated by Avan Thakkar about 2 months ago

Kiefer Chang wrote:

cephadm doesn't tear down the services on a removed host yet. Please see #47782.
I would suggest we keep revealing those services on the host list to let the admin know there are still some services.

My only concern is if we delete a host and try to see the services deployed on it in Cluster->Services, the deleted host is removed there too. And we are only able to see the updated Services list after restarting the dashboard.

Also I see that if the deleted host has some mon service running on it, Services list(upon restarting dashboard) doesn't list that host under 'mon' , but it's there in Cluster->Monitors. So my suggestion here is shouldn't we show the deleted host in Services list itself under whatever services it applies to? We can show the user a warning message saying the services deployed on this host can still be seen under Cluster->Services. What you think on this?

#5 Updated by Kiefer Chang about 2 months ago

Avan Thakkar wrote:

So my suggestion here is shouldn't we show the deleted host in Services list itself under whatever services it applies to?

You can't easily get pending hosts with services on that page. Because the orchestrator filters them out.

We can show the user a warning message saying the services deployed on this host can still be seen under Cluster->Services. What you think on this?

I'm not sure if this is correct, they can't be seen in `Cluster->Service`. But can be seen in `Cluster->Hosts` and other non-orchestrator components.

My suggestion is we should wait for #47782, instead of making workaround in the dashboard.

#6 Updated by Avan Thakkar about 2 months ago

Kiefer Chang wrote:

Avan Thakkar wrote:

So my suggestion here is shouldn't we show the deleted host in Services list itself under whatever services it applies to?

You can't easily get pending hosts with services on that page. Because the orchestrator filters them out.

We can show the user a warning message saying the services deployed on this host can still be seen under Cluster->Services. What you think on this?

I'm not sure if this is correct, they can't be seen in `Cluster->Service`. But can be seen in `Cluster->Hosts` and other non-orchestrator components.

Yes we can;t see currently, I was suggesting to show them under Services.

My suggestion is we should wait for #47782, instead of making workaround in the dashboard.

Okay, sounds good to me. I think we can then close the PR for now?

#7 Updated by Paul Cuzner about 2 months ago

I'm confused with 'why' deleting a host that has running cluster daemons on it makes sense. Shouldn't the "orchestrator host rm" check for daemons, and abort if there are daemons deployed.

To my mind there is a missing step - drain. If the admin wants to remove a host they 'hit drain' which will trigger a 'rebalance' of the daemons and remove them from the host and once drained - the host rm will just remove the host entry. Following this model allows the host status to change to draining, so it's obvious what's going on with the host.

#8 Updated by Ernesto Puerta about 1 month ago

  • Status changed from In Progress to Won't Fix

Also available in: Atom PDF