Project

General

Profile

Bug #48275

cephadm: get_last_local_ceph_image returns "<none>:<none>"

Added by Sebastian Wagner about 2 months ago. Updated about 2 months ago.

Status:
Duplicate
Priority:
Normal
Category:
-
Target version:
-
% Done:

0%

Source:
Tags:
Backport:
Regression:
No
Severity:
3 - minor
Reviewed:
Affected Versions:
ceph-qa-suite:
Pull request ID:
Crash signature:

Description

node2:~ # cephadm ceph-volume inventory
Inferring fsid 83c06a6e-298b-11eb-9c2a-525400501d50
Using recent ceph image <none>:<none>
Non-zero exit code 125 from /usr/bin/podman run --rm --ipc=host --net=host --entrypoint stat -e CONTAINER_IMAGE=<none>:<none> -e NODE_NAME=node2 <none>:<none> -c %u %g /var/lib/ceph
stat:stderr Error: invalid reference format
Traceback (most recent call last):
  File "/usr/sbin/cephadm", line 6043, in <module>
    r = args.func()
  File "/usr/sbin/cephadm", line 1299, in _infer_fsid
    return func()
  File "/usr/sbin/cephadm", line 1358, in _infer_image
    return func()
  File "/usr/sbin/cephadm", line 3558, in command_ceph_volume
    make_log_dir(args.fsid)
  File "/usr/sbin/cephadm", line 1453, in make_log_dir
    uid, gid = extract_uid_gid()
  File "/usr/sbin/cephadm", line 2061, in extract_uid_gid
    raise RuntimeError('uid/gid not found')
RuntimeError: uid/gid not found

Related issues

Related to Orchestrator - Bug #48205: cephadm: last local ceph image tag can be null Resolved
Related to Orchestrator - Bug #47134: cephadm: Unable to infer container image when tag is missing Resolved

History

#1 Updated by Sebastian Wagner about 2 months ago

  • Duplicates Bug #47134: cephadm: Unable to infer container image when tag is missing added

#2 Updated by Sebastian Wagner about 2 months ago

  • Status changed from New to Duplicate

#3 Updated by Nathan Cutler about 2 months ago

  • Status changed from Duplicate to New

This was closed as a duplicate of Orchestrator - Bug #47134: cephadm: Unable to infer container image when tag is missing, which was closed as fixed by https://github.com/ceph/ceph/pull/36797 but our cluster has that commit and this bug still manifests.

I guess #48205 was intended, not #47134.

#4 Updated by Nathan Cutler about 2 months ago

  • Duplicates deleted (Bug #47134: cephadm: Unable to infer container image when tag is missing)

#5 Updated by Nathan Cutler about 2 months ago

  • Related to Bug #48205: cephadm: last local ceph image tag can be null added

#6 Updated by Nathan Cutler about 2 months ago

  • Status changed from New to Duplicate

#7 Updated by Nathan Cutler about 2 months ago

  • Related to Bug #47134: cephadm: Unable to infer container image when tag is missing added

Also available in: Atom PDF