Project

General

Profile

Bug #48263

cephadm: ambigious container name `ceph-00000000-0000-0000-0000-0000deadbeef` being called instead of fsid

Added by Deepika Upadhyay about 1 year ago. Updated about 1 year ago.

Status:
Won't Fix
Priority:
Normal
Assignee:
-
Category:
cephadm
Target version:
-
% Done:

0%

Source:
Tags:
Backport:
octopus
Regression:
No
Severity:
3 - minor
Reviewed:
Affected Versions:
ceph-qa-suite:
Pull request ID:
Crash signature (v1):
Crash signature (v2):

Description

 Starting Ceph mon.a for 00000000-0000-0000-0000-0000deadbeef...
2020-11-17T14:32:50.754 INFO:tasks.workunit.client.0.smithi061.stdout:Nov 17 14:29:04 smithi061 podman[13348]: Error: no container with name or ID ceph-00000000-0000-0000-0000-0000deadbeef-mon.a found: no such container
2020-11-17T14:32:50.755 INFO:tasks.workunit.client.0.smithi061.stdout:Nov 17 14:29:04 smithi061 bash[13378]: Error: Failed to evict container: "": Failed to find container "ceph-00000000-0000-0000-0000-0000deadbeef-mon.a" in state: no container with name or ID ceph-00000000-0000-0000-0000-0000deadbeef-mon.a found: no such container
2020-11-17T14:32:50.755 INFO:tasks.workunit.client.0.smithi061.stdout:Nov 17 14:29:04 smithi061 bash[13378]: ceph-00000000-0000-0000-0000-0000deadbeef-mon.a
2020-11-17T14:32:50.755 INFO:tasks.workunit.client.0.smithi061.stdout:Nov 17 14:29:04 smithi061 bash[13378]: Error: no container with ID or name "ceph-00000000-0000-0000-0000-0000deadbeef-mon.a" found: no such container
2020-11-17T14:32:50.755 INFO:tasks.workunit.client.0.smithi061.stdout:Nov 17 14:29:04 smithi061 podman[13410]: 2020-11-17 14:29:04.694869764 +0000 UTC m=+0.257024188 container create 01af287fbf7ef25ab719ebb0c2efe904b5bb93cb7d68a249a13b2a4d34722d94 (image=docker.io/ceph/daemon-base:latest-octopus, name=ceph-00000000-0000-0000-0000-0000deadbeef-mon.a)
2020-11-17T14:32:50.756 INFO:tasks.workunit.client.0.smithi061.stdout:Nov 17 14:29:04 smithi061 podman[13410]: 2020-11-17 14:29:04.869774295 +0000 UTC m=+0.431928706 container init 01af287fbf7ef25ab719ebb0c2efe904b5bb93cb7d68a249a13b2a4d34722d94 (image=docker.io/ceph/daemon-base:latest-octopus, name=ceph-00000000-0000-0000-0000-0000deadbeef-mon.a)
2020-11-17T14:32:50.756 INFO:tasks.workunit.client.0.smithi061.stdout:Nov 17 14:29:04 smithi061 podman[13410]: 2020-11-17 14:29:04.903166155 +0000 UTC m=+0.465320526 container start 01af287fbf7ef25ab719ebb0c2efe904b5bb93cb7d68a249a13b2a4d34722d94 (image=docker.io/ceph/daemon-base:latest-octopus, name=ceph-00000000-0000-0000-0000-0000deadbeef-mon.a)
2020-11-17T14:32:50.756 INFO:tasks.workunit.client.0.smithi061.stdout:Nov 17 14:29:04 smithi061 bash[13378]: 01af287fbf7ef25ab719ebb0c2efe904b5bb93cb7d68a249a13b2a4d34722d94
2020-11-17T14:32:50.756 INFO:tasks.workunit.client.0.smithi061.stdout:Nov 17 14:29:04 smithi061 systemd[1]: Started Ceph mon.a for 00000000-0000-0000-0000-0000deadbeef.
2020-11-17T14:32:50.757 INFO:tasks.workunit.client.0.smithi061.stdout:Nov 17 14:29:09 smithi061 systemd[1]: Stopping Ceph mon.a for 00000000-0000-0000-0000-0000deadbeef...
2020-11-17T14:32:50.757 INFO:tasks.workunit.client.0.smithi061.stdout:Nov 17 14:29:09 smithi061 podman[13934]: 2020-11-17 14:29:09.533689735 +0000 UTC m=+0.420346305 container died 01af287fbf7ef25ab719ebb0c2efe904b5bb93cb7d68a249a13b2a4d34722d94 (image=docker.io/ceph/daemon-base:latest-octopus, name=ceph-00000000-0000-0000-0000-0000deadbeef-mon.a)
2020-11-17T14:32:50.757 INFO:tasks.workunit.client.0.smithi061.stdout:Nov 17 14:29:09 smithi061 podman[13934]: 2020-11-17 14:29:09.560909997 +0000 UTC m=+0.447566424 container stop 01af287fbf7ef25ab719ebb0c2efe904b5bb93cb7d68a249a13b2a4d34722d94 (image=docker.io/ceph/daemon-base:latest-octopus, name=ceph-00000000-0000-0000-0000-0000deadbeef-mon.a)
2020-11-17T14:32:50.757 INFO:tasks.workunit.client.0.smithi061.stdout:Nov 17 14:29:09 smithi061 podman[13934]: 01af287fbf7ef25ab719ebb0c2efe904b5bb93cb7d68a249a13b2a4d34722d94
2020-11-17T14:32:50.757 INFO:tasks.workunit.client.0.smithi061.stdout:Nov 17 14:29:10 smithi061 systemd[1]: Stopped Ceph mon.a for 00000000-0000-0000-0000-0000deadbeef.
2020-11-17T14:32:50.758 INFO:tasks.workunit.client.0.smithi061.stdout:Nov 17 14:29:10 smithi061 systemd[1]: Starting Ceph mon.a for 00000000-0000-0000-0000-0000deadbeef...
2020-11-17T14:32:50.758 INFO:tasks.workunit.client.0.smithi061.stdout:Nov 17 14:29:10 smithi061 podman[13991]: Error: no container with name or ID ceph-00000000-0000-0000-0000-0000deadbeef-mon.a found: no such container
2020-11-17T14:32:50.758 INFO:tasks.workunit.client.0.smithi061.stdout:Nov 17 14:29:10 smithi061 bash[14013]: Error: Failed to evict container: "": Failed to find container "ceph-00000000-0000-0000-0000-0000deadbeef-mon.a" in state: no container with name or ID ceph-00000000-0000-0000-0000-0000deadbeef-mon.a found: no such container

Related issues

Related to Orchestrator - Bug #44729: cephadm enter using docker is broken Can't reproduce

History

#1 Updated by Sebastian Wagner about 1 year ago

any idea where this comes from? https://github.com/ceph/ceph/search?q=deadbeef

#3 Updated by Deepika Upadhyay about 1 year ago

  • Related to Bug #44729: cephadm enter using docker is broken added

#5 Updated by Deepika Upadhyay about 1 year ago

on second look, I suppose that's not the cause of failure here. I think the daemons crashed and none was found for log dump.

umm, I would be aware of it now, maybe sometime later we can fix that, not an issue as of now.

#6 Updated by Sebastian Wagner about 1 year ago

  • Status changed from New to Won't Fix

please reopen, if you think we should improve this eventually

Also available in: Atom PDF