Project

General

Profile

Cleanup #48210

should unpin urllib3 when requests is compatible with urllib3 1.26

Added by Kefu Chai 3 months ago. Updated about 1 month ago.

Status:
Resolved
Priority:
Normal
Assignee:
Category:
-
Target version:
-
% Done:

0%

Tags:
Backport:
Reviewed:
Affected Versions:
Pull request ID:

Description

we have

ERROR: Cannot install -r requirements.txt (line 3) and kubernetes because these package versions have conflicting dependencies.

The conflict is caused by:
kubernetes 12.0.0 depends on urllib3>=1.24.2
requests 2.24.0 depends on urllib3!=1.25.0, !=1.25.1, <1.26 and >=1.21.1

as a workaround, https://github.com/ceph/ceph/pull/38021 is created. but we don't depend on a specific version of urllib3, neither do we depend on urllib3 directly (AFAIK).

so we should unpin and remove it once requests is compatible with urllib3 1.26.

History

#1 Updated by Kefu Chai about 2 months ago

  • Status changed from New to Fix Under Review
  • Assignee set to Kefu Chai
  • Pull request ID set to 38398

#2 Updated by Kefu Chai about 1 month ago

  • Status changed from Fix Under Review to Resolved

Also available in: Atom PDF