Project

General

Profile

Bug #48209

cephadm/test_dashboard_e2e.sh: OSDs are not deleted

Added by Kiefer Chang about 2 years ago. Updated almost 2 years ago.

Status:
Closed
Priority:
Normal
Assignee:
Category:
Testing & QA
Target version:
-
% Done:

0%

Source:
Community (dev)
Tags:
Backport:
Regression:
No
Severity:
3 - minor
Reviewed:
Affected Versions:
ceph-qa-suite:
Pull request ID:
Crash signature (v1):
Crash signature (v2):

Description

This failure was seen in recent runs.

https://pulpito.ceph.com/teuthology-2020-11-11_07:01:02-rados-master-distro-basic-smithi/5612605/
https://pulpito.ceph.com/kchang-2020-11-12_02:37:31-rados:cephadm:dashboard-wip-kiefer-testing-2020-11-11-1114-distro-basic-smithi/

2020-11-11T23:15:03.191 INFO:tasks.workunit.client.0.smithi199.stdout:  Running:  orchestrator/04-osds.e2e-spec.ts                                                (1 of 1)
2020-11-11T23:15:05.140 INFO:tasks.workunit.client.0.smithi199.stderr:Couldn't determine Mocha version
2020-11-11T23:15:05.144 INFO:tasks.workunit.client.0.smithi199.stdout:
2020-11-11T23:15:05.149 INFO:tasks.workunit.client.0.smithi199.stdout:
2020-11-11T23:15:05.156 INFO:tasks.workunit.client.0.smithi199.stdout:  OSDs page
2020-11-11T23:15:05.157 INFO:tasks.workunit.client.0.smithi199.stdout:    when Orchestrator is available
2020-11-11T23:25:47.346 INFO:tasks.workunit.client.0.smithi199.stdout:      1) should create and delete OSDs
2020-11-11T23:25:47.774 INFO:tasks.workunit.client.0.smithi199.stdout:
2020-11-11T23:25:47.776 INFO:tasks.workunit.client.0.smithi199.stdout:
2020-11-11T23:25:47.776 INFO:tasks.workunit.client.0.smithi199.stdout:  0 passing (11m)
2020-11-11T23:25:47.776 INFO:tasks.workunit.client.0.smithi199.stdout:  1 failing
2020-11-11T23:25:47.776 INFO:tasks.workunit.client.0.smithi199.stdout:
2020-11-11T23:25:47.777 INFO:tasks.workunit.client.0.smithi199.stdout:  1) OSDs page
2020-11-11T23:25:47.777 INFO:tasks.workunit.client.0.smithi199.stdout:       when Orchestrator is available
2020-11-11T23:25:47.777 INFO:tasks.workunit.client.0.smithi199.stdout:         should create and delete OSDs:
2020-11-11T23:25:47.777 INFO:tasks.workunit.client.0.smithi199.stdout:     CypressError: Timed out retrying: `cy.click()` failed because this element is `disabled`:
2020-11-11T23:25:47.777 INFO:tasks.workunit.client.0.smithi199.stdout:
2020-11-11T23:25:47.778 INFO:tasks.workunit.client.0.smithi199.stdout:`<button _ngcontent-pmq-c168="" type="button" data-toggle="tooltip" class="btn btn-light" title="No available devices" 
disabled="">...</button>`
2020-11-11T23:25:47.778 INFO:tasks.workunit.client.0.smithi199.stdout:
2020-11-11T23:25:47.778 INFO:tasks.workunit.client.0.smithi199.stdout:Fix this problem, or use `{force: true}` to disable error checking.
2020-11-11T23:25:47.778 INFO:tasks.workunit.client.0.smithi199.stdout:
2020-11-11T23:25:47.778 INFO:tasks.workunit.client.0.smithi199.stdout:https://on.cypress.io/element-cannot-be-interacted-with
2020-11-11T23:25:47.778 INFO:tasks.workunit.client.0.smithi199.stdout:      at $Cy.ensureNotDisabled (https://smithi199:8443/__cypress/runner/cypress_runner.js:160988:24)
2020-11-11T23:25:47.778 INFO:tasks.workunit.client.0.smithi199.stdout:      at runAllChecks (https://smithi199:8443/__cypress/runner/cypress_runner.js:150015:14)
2020-11-11T23:25:47.779 INFO:tasks.workunit.client.0.smithi199.stdout:      at retryActionability (https://smithi199:8443/__cypress/runner/cypress_runner.js:150071:16)
2020-11-11T23:25:47.779 INFO:tasks.workunit.client.0.smithi199.stdout:      at tryCatcher (https://smithi199:8443/__cypress/runner/cypress_runner.js:10325:23)
2020-11-11T23:25:47.779 INFO:tasks.workunit.client.0.smithi199.stdout:      at Function.Promise.attempt.Promise.try (https://smithi199:8443/__cypress/runner/cypress_runner.js:7599:29)
2020-11-11T23:25:47.779 INFO:tasks.workunit.client.0.smithi199.stdout:      at tryFn (https://smithi199:8443/__cypress/runner/cypress_runner.js:165189:21)
2020-11-11T23:25:47.779 INFO:tasks.workunit.client.0.smithi199.stdout:      at whenStable (https://smithi199:8443/__cypress/runner/cypress_runner.js:165227:12)
2020-11-11T23:25:47.779 INFO:tasks.workunit.client.0.smithi199.stdout:      at https://smithi199:8443/__cypress/runner/cypress_runner.js:164742:16
2020-11-11T23:25:47.779 INFO:tasks.workunit.client.0.smithi199.stdout:      at tryCatcher (https://smithi199:8443/__cypress/runner/cypress_runner.js:10325:23)
2020-11-11T23:25:47.780 INFO:tasks.workunit.client.0.smithi199.stdout:      at Promise._settlePromiseFromHandler (https://smithi199:8443/__cypress/runner/cypress_runner.js:8260:31)
2020-11-11T23:25:47.780 INFO:tasks.workunit.client.0.smithi199.stdout:      at Promise._settlePromise (https://smithi199:8443/__cypress/runner/cypress_runner.js:8317:18)
2020-11-11T23:25:47.780 INFO:tasks.workunit.client.0.smithi199.stdout:      at Promise._settlePromise0 (https://smithi199:8443/__cypress/runner/cypress_runner.js:8362:10)
2020-11-11T23:25:47.780 INFO:tasks.workunit.client.0.smithi199.stdout:      at Promise._settlePromises (https://smithi199:8443/__cypress/runner/cypress_runner.js:8442:18)
2020-11-11T23:25:47.780 INFO:tasks.workunit.client.0.smithi199.stdout:      at Promise._fulfill (https://smithi199:8443/__cypress/runner/cypress_runner.js:8386:18)
2020-11-11T23:25:47.780 INFO:tasks.workunit.client.0.smithi199.stdout:      at https://smithi199:8443/__cypress/runner/cypress_runner.js:10000:46
2020-11-11T23:25:47.780 INFO:tasks.workunit.client.0.smithi199.stdout:  From Your Spec Code:

History

#1 Updated by Kiefer Chang about 2 years ago

  • Status changed from New to In Progress
  • Assignee set to Kiefer Chang

#2 Updated by Kiefer Chang about 2 years ago

  • Subject changed from cephadm/test_dashboard_e2e.sh: OSDs are not created to cephadm/test_dashboard_e2e.sh: OSDs are not deleted

The failure log is misleading because it's the log of second attempt.
After running the test manually, the actuall failure is on OSD deleting.
The reason is the column order change introduced in https://github.com/ceph/ceph/pull/37506

#3 Updated by Kiefer Chang about 2 years ago

  • Status changed from In Progress to Fix Under Review
  • Pull request ID set to 38038

#4 Updated by Kefu Chai about 2 years ago

  • Status changed from Fix Under Review to Resolved

#5 Updated by Ernesto Puerta about 2 years ago

  • Status changed from Resolved to Closed

#6 Updated by Ernesto Puerta almost 2 years ago

  • Project changed from mgr to Dashboard
  • Category changed from 151 to Testing & QA

Also available in: Atom PDF