Project

General

Profile

Bug #482

cephx assert

Added by Sage Weil over 10 years ago. Updated over 10 years ago.

Status:
Closed
Priority:
Normal
Assignee:
-
Category:
-
Target version:
% Done:

0%

Source:
Tags:
Backport:
Regression:
No
Severity:
3 - minor
Reviewed:
Affected Versions:
ceph-qa-suite:
Pull request ID:
Crash signature:

Description

e5882981b55f3c74d6b8b22a2bf5fbec81b775e6

10.10.13_11:45:30.241022 7f393a2a2910 cephx client:  unknown request_type 44545
auth/cephx/CephxClientHandler.cc: In function 'virtual int CephxClientHandler::handle_response(int, ceph::buffer::list::iterator&)':
auth/cephx/CephxClientHandler.cc:162: FAILED assert(0)
 1: (CephxClientHandler::handle_response(int, ceph::buffer::list::iterator&)+0x742) [0x86ea5c]
 2: (MonClient::handle_auth(MAuthReply*)+0x32b) [0x855bd1]
 3: (MonClient::ms_dispatch(Message*)+0xf3) [0x854c0b]
 4: (Messenger::ms_deliver_dispatch(Message*)+0x63) [0x674519]
 5: (SimpleMessenger::dispatch_entry()+0x5d4) [0x6667a0]
 6: (SimpleMessenger::DispatchThread::entry()+0x2c) [0x65bb40]
 7: (Thread::_entry_func(void*)+0x23) [0x6733e3]
 8: /lib/libpthread.so.0 [0x7f3941d9d73a]
 9: (clone()+0x6d) [0x7f3940fc669d]
 NOTE: a copy of the executable, or `objdump -rdS <executable>` is needed to interpret this.

on ballpit3

History

#1 Updated by Sage Weil over 10 years ago

  • Status changed from New to Closed

We decided this was caused by walking off into the weeds due to #484.

Also available in: Atom PDF