Project

General

Profile

Bug #48147

qa: vstart_runner crashes when run with kernel client

Added by Rishabh Dave 2 months ago. Updated 2 months ago.

Status:
Resolved
Priority:
Normal
Assignee:
Category:
-
Target version:
% Done:

0%

Source:
Development
Tags:
Backport:
Regression:
No
Severity:
3 - minor
Reviewed:
Affected Versions:
ceph-qa-suite:
Component(FS):
Labels (FS):
qa
Pull request ID:
Crash signature:

Description

Addition of line self.rbytes = config.get("rbytes", False) to kernel_mount.py leads to crash when testcases are run using kernel client with vstart_runner.py since the value of config is None in case of vstart_runner. Following traceback can be seen by running python3 ../qa/tasks/vstart_runner.py tasks.cephfs.test_cephfs_shell.TestCD.test_cd_with_args --kclient -

Traceback (most recent call last):
  File "../qa/tasks/vstart_runner.py", line 1532, in <module>
    exec_test()
  File "../qa/tasks/vstart_runner.py", line 1428, in exec_test
    mount = LocalKernelMount(ctx=ctx, test_dir=test_dir,
  File "../qa/tasks/vstart_runner.py", line 668, in __init__
    super(LocalKernelMount, self).__init__(ctx=ctx, test_dir=test_dir,
  File "/home/rishabh/repos/ceph/minor/qa/tasks/cephfs/kernel_mount.py", line 28, in __init__
    self.rbytes = config.get('rbytes', False)
AttributeError: 'NoneType' object has no attribute 'get'

Here's the commit that introduced this code.

History

#1 Updated by Rishabh Dave 2 months ago

  • Assignee set to Rishabh Dave

#2 Updated by Rishabh Dave 2 months ago

  • Pull request ID set to 37982

#3 Updated by Patrick Donnelly 2 months ago

  • Status changed from In Progress to Resolved
  • Target version set to v16.0.0
  • Source set to Development

Also available in: Atom PDF