Project

General

Profile

Bug #48122

rgw cannot find keyring after config file is minimized

Added by Wyllys Ingersoll 6 months ago. Updated about 7 hours ago.

Status:
Won't Fix
Priority:
Normal
Assignee:
-
Target version:
% Done:

0%

Source:
Community (user)
Tags:
rgw, config, cli
Backport:
nautilus, octopus
Regression:
No
Severity:
2 - major
Reviewed:
ceph-qa-suite:
Pull request ID:
Crash signature (v1):
Crash signature (v2):

Description

Given a ceph.conf file like this:

[client.radosgw.gateway]
keyring = /etc/ceph/ceph.client.radosgw.keyring

When converting to the new minimized configuration file format using the "ceph config generate-minimal-conf" command, the gateway configurations are removed. If the keyring location was one of the values and it pointed to a location other than /var/lib/ceph/radosgw/ceph-radosgw.gwname/keyring, the radosgw service cannot start because it cannot find the keyring and it cannot ask the monitor since it doesn't have a keyring to talk to the monitor.

The generate-minimal-conf command should either NOT remove parameters that cannot be stored in the monitor, or at least warn the user that some parameters could not be converted so they can be added to the new config file as needed.

History

#1 Updated by Nathan Cutler 6 months ago

  • Project changed from rgw to Ceph
  • Description updated (diff)
  • Target version changed from v14.2.14 to v16.0.0
  • Tags changed from rgw, config to rgw, config, cli
  • Backport set to nautilus, octopus

#2 Updated by Nathan Cutler 6 months ago

  • Affected Versions v14.2.13, v15.2.5, v16.0.0 added

#3 Updated by Nathan Cutler 6 months ago

  • Severity changed from 3 - minor to 2 - major

Moved to "Ceph" project since it's a bug in the implementation of "ceph config generate-minimal-conf".

#4 Updated by Sage Weil 1 day ago

  • Project changed from Ceph to rgw

#5 Updated by Casey Bodley about 7 hours ago

  • Status changed from New to Won't Fix

Also available in: Atom PDF