Project

General

Profile

Bug #47980

sepia: openvpn can't finish tls handshake

Added by Xuehan Xu 7 months ago. Updated 7 months ago.

Status:
Resolved
Priority:
Normal
Assignee:
Category:
User access
Target version:
-
% Done:

0%

Source:
Tags:
Backport:
Regression:
No
Severity:
3 - minor
Reviewed:
Affected Versions:
ceph-qa-suite:
Crash signature (v1):
Crash signature (v2):

Description

Recently, I can't connect to any of the sepia machines, and my openvpn keep prmopting the following error:

Oct 26 09:50:15 ceph01v openvpn[4145186]: Mon Oct 26 09:50:15 2020 UDP link remote: [AF_INET]8.43.84.129:1194
Oct 26 09:51:15 ceph01v openvpn[4145186]: Mon Oct 26 09:51:15 2020 TLS Error: TLS key negotiation failed to occur within 60 seconds (check your network connectivity)
Oct 26 09:51:15 ceph01v openvpn[4145186]: Mon Oct 26 09:51:15 2020 TLS Error: TLS handshake failed
Oct 26 09:51:15 ceph01v openvpn[4145186]: Mon Oct 26 09:51:15 2020 SIGUSR1[soft,tls-error] received, process restarting
Oct 26 09:56:15 ceph01v openvpn[4145186]: Mon Oct 26 09:56:15 2020 TCP/UDP: Preserving recently used remote address: [AF_INET]8.43.84.129:1194
Oct 26 09:56:15 ceph01v openvpn[4145186]: Mon Oct 26 09:56:15 2020 UDP link local: (not bound)
Oct 26 09:56:15 ceph01v openvpn[4145186]: Mon Oct 26 09:56:15 2020 UDP link remote: [AF_INET]8.43.84.129:1194
Oct 26 09:57:15 ceph01v openvpn[4145186]: Mon Oct 26 09:57:15 2020 TLS Error: TLS key negotiation failed to occur within 60 seconds (check your network connectivity)
Oct 26 09:57:15 ceph01v openvpn[4145186]: Mon Oct 26 09:57:15 2020 TLS Error: TLS handshake failed
Oct 26 09:57:15 ceph01v openvpn[4145186]: Mon Oct 26 09:57:15 2020 SIGUSR1[soft,tls-error] received, process restarting

I can ping 8.43.84.129, but can't telnet to port 1194.

History

#1 Updated by adam kraitman 7 months ago

  • Category changed from Infrastructure Service to User access
  • Status changed from New to In Progress
  • Assignee set to adam kraitman

#2 Updated by Xuehan Xu 7 months ago

hi, adam, this seems to be a problem with my own network, please feel free to close this ticket, sorry for the bother.

#3 Updated by adam kraitman 7 months ago

  • Status changed from In Progress to Resolved

#4 Updated by Xuehan Xu 7 months ago

Um...Adam, I have a need for teuthology-kill access, could you grant that to me? Thanks:-)

Also available in: Atom PDF