Project

General

Profile

Bug #47922

rook: Failed to load ceph-mgr modules: cephadm, dashboard

Added by Varsha Rao 3 months ago. Updated 3 months ago.

Status:
Closed
Priority:
Normal
Assignee:
-
Category:
mgr/rook
Target version:
% Done:

0%

Source:
Community (dev)
Tags:
Backport:
octopus
Regression:
No
Severity:
3 - minor
Reviewed:
Affected Versions:
ceph-qa-suite:
Pull request ID:
Crash signature:

Description

Mgr log

debug 2020-10-21T07:53:03.172+0000 7faed5f9e3c0 -1 mgr[py] Module not found: 'cephadm'
debug 2020-10-21T07:53:03.176+0000 7faed5f9e3c0 -1 mgr[py] Traceback (most recent call last):
  File "/usr/share/ceph/mgr/cephadm/__init__.py", line 6, in <module>
    from .module import CephadmOrchestrator
  File "/usr/share/ceph/mgr/cephadm/module.py", line 26, in <module>
    from ceph.deployment.service_spec import \
ImportError: cannot import name 'CustomContainerSpec'

debug 2020-10-21T07:53:03.212+0000 7faed5f9e3c0 -1 mgr[py] Class not found in module 'cephadm'
debug 2020-10-21T07:53:03.212+0000 7faed5f9e3c0 -1 mgr[py] Error loading module 'cephadm': (2) No such file or directory
debug 2020-10-21T07:53:03.212+0000 7faed5f9e3c0  1 mgr[py] Loading python module 'crash'
debug 2020-10-21T07:53:03.536+0000 7faed5f9e3c0  1 mgr[py] Loading python module 'dashboard'
debug 2020-10-21T07:53:06.160+0000 7faed5f9e3c0 -1 mgr[py] Module not found: 'dashboard'
debug 2020-10-21T07:53:06.160+0000 7faed5f9e3c0 -1 mgr[py] Traceback (most recent call last):
  File "/usr/share/ceph/mgr/dashboard/__init__.py", line 53, in <module>
    from .module import Module, StandbyModule  # noqa: F401
  File "/usr/share/ceph/mgr/dashboard/module.py", line 21, in <module>
    from .controllers import generate_routes, json_error_page
  File "/usr/share/ceph/mgr/dashboard/controllers/__init__.py", line 25, in <module>
    from ..tools import TaskManager, get_request_body_params, getargspec
  File "/usr/share/ceph/mgr/dashboard/tools.py", line 16, in <module>
    from ceph.deployment.utils import wrap_ipv6
ModuleNotFoundError: No module named 'ceph.deployment.utils'

debug 2020-10-21T07:53:06.228+0000 7faed5f9e3c0 -1 mgr[py] Class not found in module 'dashboard'
debug 2020-10-21T07:53:06.228+0000 7faed5f9e3c0 -1 mgr[py] Error loading module 'dashboard': (2) No such file or directory

[root@rook-ceph-tools-78cdfd976c-gj55c /]# ceph version
ceph version 16.0.0-4762-ga1c3f3b (a1c3f3b7cfe7cd69ea4218393490b61c4e03e716) pacific (dev)
[root@rook-ceph-tools-78cdfd976c-gj55c /]# rook version
rook: v1.4.0-alpha.0.499.g40068a95
go: go1.15.2
[root@rook-ceph-tools-78cdfd976c-gj55c /]# ceph -s
  cluster:
    id:     577e124f-8d39-4858-84a7-a6310f34beaa
    health: HEALTH_WARN
            Module 'dashboard' has failed dependency: No module named 'ceph.deployment.utils'

  services:
    mon: 1 daemons, quorum a (age 24m)
    mgr: a(active, since 7m)
    osd: 1 osds: 1 up (since 21m), 1 in (since 21m)

  data:
    pools:   1 pools, 1 pgs
    objects: 0 objects, 0 B
    usage:   4.9 MiB used, 25 GiB / 25 GiB avail
    pgs:     1 active+clean

History

#1 Updated by Varsha Rao 3 months ago

  • Status changed from New to Closed

This issue no longer occurs with latest master branch image.

Also available in: Atom PDF