Project

General

Profile

Bug #47786

mds: log [ERR] : failed to commit dir 0x100000005f1.1010* object, errno -2

Added by Patrick Donnelly 4 months ago. Updated about 2 months ago.

Status:
Resolved
Priority:
High
Assignee:
Category:
-
Target version:
% Done:

0%

Source:
Q/A
Tags:
Backport:
Regression:
No
Severity:
3 - minor
Reviewed:
Affected Versions:
ceph-qa-suite:
Component(FS):
MDS
Labels (FS):
crash, qa-failure
Pull request ID:
Crash signature:

Description

2020-10-07T07:04:10.507 INFO:tasks.workunit.client.1.smithi131.stdout:creating folder hierarchy
2020-10-07T07:04:10.508 INFO:tasks.workunit.client.0.smithi131.stdout:creating folder hierarchy
2020-10-07T07:05:47.310 INFO:tasks.workunit.client.0.smithi131.stdout:created hierarchy, now cleaning up
2020-10-07T07:06:03.173 INFO:tasks.workunit.client.1.smithi131.stdout:created hierarchy, now cleaning up
2020-10-07T07:07:34.033 INFO:tasks.ceph.mds.e.smithi188.stderr:2020-10-07T07:07:34.033+0000 7f277a22b700 -1 log_channel(cluster) log [ERR] : failed to commit dir 0x100000005f1.1010* object, errno -2
2020-10-07T07:07:34.034 INFO:tasks.ceph.mds.e.smithi188.stderr:2020-10-07T07:07:34.033+0000 7f277a22b700 -1 mds.2.11 unhandled write error (2) No such file or directory, force readonly...
2020-10-07T07:07:34.261 INFO:tasks.workunit.client.1.smithi131.stderr:rm: cannot remove 'file3634': Read-only file system
2020-10-07T07:07:51.142 INFO:tasks.workunit.client.0.smithi131.stderr:rm: cannot remove 'file2015': Read-only file system
2020-10-07T07:07:55.225 INFO:tasks.workunit.client.0.smithi131.stderr:rm: cannot remove 'file7403': Read-only file system

From: /ceph/teuthology-archive/pdonnell-2020-10-07_03:30:19-multimds-wip-pdonnell-testing-20201007.015751-distro-basic-smithi/5503230/teuthology.log

History

#1 Updated by Patrick Donnelly 4 months ago

/ceph/teuthology-archive/pdonnell-2020-10-08_01:40:56-multimds-wip-pdonnell-testing-20201007.214100-distro-basic-smithi/5505513/teuthology.log
/ceph/teuthology-archive/pdonnell-2020-10-08_01:40:56-multimds-wip-pdonnell-testing-20201007.214100-distro-basic-smithi/5505529/teuthology.log

#2 Updated by Patrick Donnelly 4 months ago

  • Labels (FS) qa-failure added

#3 Updated by Patrick Donnelly 4 months ago

  • Assignee set to Zheng Yan

#4 Updated by Zheng Yan 3 months ago

For /ceph/teuthology-archive/pdonnell-2020-10-08_01:40:56-multimds-wip-pdonnell-testing-20201007.214100-distro-basic-smithi/5505529/teuthology.log. looks like osd_op(mds.0.4:2340 ...) got lost. no idea what happened

#5 Updated by Patrick Donnelly 3 months ago

$ grep 'failed to commit dir' pdonnell-2020-10-*/*/teu*
Binary file pdonnell-2020-10-07_03:30:19-multimds-wip-pdonnell-testing-20201007.015751-distro-basic-smithi/5503172/teuthology.log matches
Binary file pdonnell-2020-10-07_03:30:19-multimds-wip-pdonnell-testing-20201007.015751-distro-basic-smithi/5503230/teuthology.log matches
Binary file pdonnell-2020-10-07_03:30:19-multimds-wip-pdonnell-testing-20201007.015751-distro-basic-smithi/5503294/teuthology.log matches
Binary file pdonnell-2020-10-08_01:40:56-multimds-wip-pdonnell-testing-20201007.214100-distro-basic-smithi/5505513/teuthology.log matches
Binary file pdonnell-2020-10-08_01:40:56-multimds-wip-pdonnell-testing-20201007.214100-distro-basic-smithi/5505529/teuthology.log matches
Binary file pdonnell-2020-10-09_03:07:06-multimds-wip-pdonnell-testing-20201009.012350-distro-basic-smithi/5507547/teuthology.log matches
Binary file pdonnell-2020-10-09_03:07:06-multimds-wip-pdonnell-testing-20201009.012350-distro-basic-smithi/5507693/teuthology.log matches
Binary file pdonnell-2020-10-09_05:10:50-multimds-wip-pdonnell-testing-20201009.020122-distro-basic-smithi/5508855/teuthology.log matches
Binary file pdonnell-2020-10-09_05:10:50-multimds-wip-pdonnell-testing-20201009.020122-distro-basic-smithi/5508857/teuthology.log matches
Binary file pdonnell-2020-10-13_22:16:53-multimds-wip-pdonnell-testing-20201013.174240-distro-basic-smithi/5524196/teuthology.log matches

#6 Updated by Patrick Donnelly 3 months ago

/ceph/teuthology-archive/pdonnell-2020-10-24_06:29:44-multimds-wip-pdonnell-testing-20201024.032205-distro-basic-smithi/5553897/teuthology.log

#7 Updated by Zheng Yan 2 months ago

  • Status changed from New to Fix Under Review
  • Pull request ID set to 38083

#8 Updated by Patrick Donnelly about 2 months ago

  • Status changed from Fix Under Review to Resolved

Also available in: Atom PDF