Project

General

Profile

Bug #4741

MDS: stuck in clientreplay

Added by Greg Farnum almost 8 years ago. Updated over 4 years ago.

Status:
Duplicate
Priority:
High
Assignee:
-
Category:
-
Target version:
% Done:

0%

Source:
Development
Tags:
Backport:
Regression:
Severity:
3 - minor
Reviewed:
Affected Versions:
ceph-qa-suite:
Component(FS):
MDS
Labels (FS):
Pull request ID:
Crash signature (v1):
Crash signature (v2):

Description

/a/teuthology-2013-04-17_01:00:56-fs-master-testing-basic/14249

I can't find any hints, except that it is in fact asking to stay in clientreplay

History

#1 Updated by Greg Farnum almost 8 years ago

Also /a/teuthology-2013-04-18_01:01:07-fs-next-testing-basic/15101

#2 Updated by Sam Lang almost 8 years ago

  • Status changed from New to Duplicate

This is a duplicate of #4742. It looks like setattr is the culprit. I was able to generate a core file of the mds while it was in this state, and the only request sitting in mds->mdcache->active_requests is the setattr which the client is waiting for (and already has an unsafe reply to). I have the dump of the mds cache as well, all that it shows for the inode the setattr is operating on is that its dirty.

#3 Updated by Greg Farnum almost 8 years ago

Interesting; on #4742 it was clearly waiting on a request because it kept saying "still have 1 active replay requests" as soon as I turned on logging, whereas these two didn't. That log line is output from MDS::_dispatch() so I guess maybe #4742 got another request that kept retrying, whereas these ones didn't? Or perhaps something else which I can't guess the significance of.

#4 Updated by Greg Farnum over 4 years ago

  • Component(FS) MDS added

Also available in: Atom PDF