Project

General

Profile

Bug #47337

CephFS - Feature #47587: pybind/mgr/nfs: add Rook support

rook: 'ceph orch ls' fails

Added by Varsha Rao 5 months ago. Updated 4 months ago.

Status:
Closed
Priority:
Normal
Assignee:
-
Category:
mgr/rook
Target version:
% Done:

0%

Source:
Community (dev)
Tags:
Backport:
Regression:
No
Severity:
3 - minor
Reviewed:
Affected Versions:
ceph-qa-suite:
Pull request ID:
Crash signature:

Description

[root@rook-ceph-tools-6b4889fdfd-86t7w /]# ceph version
ceph version 15.2.4 (7447c15c6ff58d7fce91843b705a268a1917325c) octopus (stable)
[root@rook-ceph-tools-6b4889fdfd-86t7w /]# rook version
rook: v1.4.0-alpha.0.291.gbd69367
go: go1.13.8

[root@rook-ceph-tools-6b4889fdfd-86t7w /]# ceph -s
  cluster:
    id:     3cb96e62-af8d-4281-ab3a-59eee430bd28
    health: HEALTH_OK

  services:
    mon: 1 daemons, quorum a (age 26m)
    mgr: a(active, since 10m)
    osd: 1 osds: 1 up (since 25m), 1 in (since 25m)

  data:
    pools:   1 pools, 1 pgs
    objects: 0 objects, 0 B
    usage:   1.0 GiB used, 10 GiB / 11 GiB avail
    pgs:     1 active+clean

[root@rook-ceph-tools-6b4889fdfd-86t7w /]# ceph orch status
Backend: rook
Available: True

From mgr log

debug 2020-09-07T11:10:34.732+0000 7fc5767d0700  0 log_channel(audit) log [DBG] : from='client.4400 -' entity='client.admin' cmd=[{"prefix": "orch ls", "target": ["mon-mgr", ""]}]: dispatch
debug 2020-09-07T11:10:34.744+0000 7fc573fce700  0 [rook ERROR orchestrator._interface] _Promise failed
Traceback (most recent call last):
  File "/usr/share/ceph/mgr/orchestrator/_interface.py", line 274, in _finalize
    next_result = self._on_complete(self._value)
  File "/usr/share/ceph/mgr/rook/module.py", line 53, in <lambda>
    return RookCompletion(on_complete=lambda _: f(*args, **kwargs))
  File "/usr/share/ceph/mgr/rook/module.py", line 265, in describe_service
    "cephclusters/{0}".format(self.rook_cluster.rook_env.cluster_name))
  File "/usr/share/ceph/mgr/rook/rook_cluster.py", line 222, in rook_api_get
    return self.rook_api_call("GET", path, **kwargs)
  File "/usr/share/ceph/mgr/rook/rook_cluster.py", line 219, in rook_api_call
    **kwargs)
  File "/lib/python3.6/site-packages/kubernetes/client/api_client.py", line 345, in call_api
    _preload_content, _request_timeout)
  File "/lib/python3.6/site-packages/kubernetes/client/api_client.py", line 176, in __call_api
    _request_timeout=_request_timeout)
  File "/lib/python3.6/site-packages/kubernetes/client/api_client.py", line 366, in request
    headers=headers)
  File "/lib/python3.6/site-packages/kubernetes/client/rest.py", line 241, in GET
    query_params=query_params)
  File "/lib/python3.6/site-packages/kubernetes/client/rest.py", line 231, in request
    raise ApiException(http_resp=r)
kubernetes.client.rest.ApiException: (404)
Reason: Not Found
HTTP response headers: HTTPHeaderDict({'Cache-Control': 'no-cache, private', 'Content-Type': 'application/json', 'Date': 'Mon, 07 Sep 2020 11:10:34 GMT', 'Content-Length': '238'})
HTTP response body: {"kind":"Status","apiVersion":"v1","metadata":{},"status":"Failure","message":"cephclusters.ceph.rook.io \"rook-ceph\" not found","reason":"NotFound","details":{"name":"rook-ceph","group":"ceph.rook.io","kind":"cephclusters"},"code":404}

debug 2020-09-07T11:10:35.048+0000 7fc573fce700 -1 mgr handle_command module 'orchestrator' command handler threw exception: (404)
Reason: Not Found
HTTP response headers: HTTPHeaderDict({'Cache-Control': 'no-cache, private', 'Content-Type': 'application/json', 'Date': 'Mon, 07 Sep 2020 11:10:34 GMT', 'Content-Length': '238'})
HTTP response body: {"kind":"Status","apiVersion":"v1","metadata":{},"status":"Failure","message":"cephclusters.ceph.rook.io \"rook-ceph\" not found","reason":"NotFound","details":{"name":"rook-ceph","group":"ceph.rook.io","kind":"cephclusters"},"code":404}

debug 2020-09-07T11:10:35.048+0000 7fc573fce700 -1 mgr.server reply reply (22) Invalid argument Traceback (most recent call last):
  File "/usr/share/ceph/mgr/mgr_module.py", line 1167, in _handle_command
    return self.handle_command(inbuf, cmd)
  File "/usr/share/ceph/mgr/orchestrator/_interface.py", line 113, in handle_command
    return dispatch[cmd['prefix']].call(self, cmd, inbuf)
  File "/usr/share/ceph/mgr/mgr_module.py", line 311, in call
    return self.func(mgr, **kwargs)
  File "/usr/share/ceph/mgr/orchestrator/_interface.py", line 75, in <lambda>
    wrapper_copy = lambda *l_args, **l_kwargs: wrapper(*l_args, **l_kwargs)
  File "/usr/share/ceph/mgr/orchestrator/_interface.py", line 66, in wrapper
    return func(*args, **kwargs)
  File "/usr/share/ceph/mgr/orchestrator/module.py", line 339, in _list_services
    raise_if_exception(completion)
  File "/usr/share/ceph/mgr/orchestrator/_interface.py", line 633, in raise_if_exception
    raise e
kubernetes.client.rest.ApiException: (404)
Reason: Not Found
HTTP response headers: HTTPHeaderDict({'Cache-Control': 'no-cache, private', 'Content-Type': 'application/json', 'Date': 'Mon, 07 Sep 2020 11:10:34 GMT', 'Content-Length': '238'})
HTTP response body: {"kind":"Status","apiVersion":"v1","metadata":{},"status":"Failure","message":"cephclusters.ceph.rook.io \"rook-ceph\" not found","reason":"NotFound","details":{"name":"rook-ceph","group":"ceph.rook.io","kind":"cephclusters"},"code":404}


Related issues

Related to Orchestrator - Bug #47387: rook: 'ceph orch ps' does not list daemons correctly Resolved

History

#1 Updated by Sebastian Wagner 5 months ago

  • Related to Bug #47387: rook: 'ceph orch ps' does not list daemons correctly added

#2 Updated by Varsha Rao 4 months ago

  • Related to Feature #47490: Integration of dashboard with volume/nfs module added

#3 Updated by Varsha Rao 4 months ago

  • Status changed from New to Closed

Not a bug in rook orchestrator module. Rather it was an issue in rook itself. This PR1 fixes it.
[1] https://github.com/rook/rook/pull/6269

#4 Updated by Patrick Donnelly 4 months ago

  • Parent task set to #47587

#5 Updated by Patrick Donnelly 4 months ago

  • Related to deleted (Feature #47490: Integration of dashboard with volume/nfs module)

Also available in: Atom PDF