Project

General

Profile

Actions

Feature #47139

closed

Require a minimum version for podman/docker

Added by Adam King over 3 years ago. Updated about 3 years ago.

Status:
Resolved
Priority:
Normal
Category:
-
Target version:
-
% Done:

0%

Source:
Tags:
Backport:
Reviewed:
Affected Versions:
Pull request ID:

Description

Requiring a minimum version for podman/docker (and just pre-reqs in general) will reduce qa overhead and make it easier for improvements such as https://tracker.ceph.com/issues/44055


Related issues 3 (0 open3 closed)

Related to Orchestrator - Feature #44055: cephadm: make 'ls' fasterClosedPaul Cuzner

Actions
Related to Orchestrator - Bug #48171: catatonit not available on CentOSResolvedMichael Fritch

Actions
Related to Orchestrator - Bug #48072: ppa:projectatomic is no longer maintainedResolvedMichael Fritch

Actions
Actions #1

Updated by Paul Cuzner over 3 years ago

+1000
the check_host code currently does no checking at all on component versions that ceph functionality depends on - it's only checking for the existence of a binary!

We should be checking for version consistency to ensure the interaction during orchestrator functions is more robust.

Actions #2

Updated by Sebastian Wagner over 3 years ago

Actions #3

Updated by Sebastian Wagner over 3 years ago

requiring podman >= 2.0 also for centos would make things a lot easier! Like #47139

Actions #4

Updated by Sebastian Wagner over 3 years ago

  • Related to Bug #48171: catatonit not available on CentOS added
Actions #5

Updated by Sebastian Wagner over 3 years ago

  • Related to Bug #48072: ppa:projectatomic is no longer maintained added
Actions #6

Updated by Michael Fritch over 3 years ago

  • Status changed from New to In Progress
  • Assignee set to Michael Fritch
Actions #7

Updated by Michael Fritch about 3 years ago

  • Status changed from In Progress to Fix Under Review
  • Pull request ID set to 39007
Actions #8

Updated by Sebastian Wagner about 3 years ago

  • Status changed from Fix Under Review to Pending Backport
Actions #9

Updated by Sebastian Wagner about 3 years ago

we can't backport podman >= 2.0 to octopus! Old octopus versions don#t support podman 2, thus we have to have a way for users to upgrade to a later octopus version without the need to upgrade to podman 2 before.

Actions #10

Updated by Sebastian Wagner about 3 years ago

  • Status changed from Pending Backport to Resolved
Actions

Also available in: Atom PDF