Project

General

Profile

Bug #47125

mds: fix possible crash when the MDS is stopping

Added by Xiubo Li 5 months ago. Updated 3 months ago.

Status:
Resolved
Priority:
Normal
Assignee:
Category:
-
Target version:
% Done:

0%

Source:
Development
Tags:
Backport:
octopus,nautilus
Regression:
No
Severity:
3 - minor
Reviewed:
Affected Versions:
ceph-qa-suite:
Component(FS):
osdc
Labels (FS):
crash
Pull request ID:
Crash signature:

Description

While the MDS daemon is stopping and if it call journaler->flush(), it may be crash dues to the onsafe parameter in Journaler:flush() is NULL as default. We need to check it first before calling the onsafe->complete().


Related issues

Copied to CephFS - Backport #47252: nautilus: mds: fix possible crash when the MDS is stopping Resolved
Copied to CephFS - Backport #47253: octopus: mds: fix possible crash when the MDS is stopping Resolved

History

#1 Updated by Xiubo Li 5 months ago

  • Status changed from New to In Progress

Before I have hit one crash without any useful logs months ago, just be possible caused by this.

#2 Updated by Xiubo Li 5 months ago

  • Status changed from In Progress to Fix Under Review
  • Pull request ID set to 36777

#3 Updated by Patrick Donnelly 5 months ago

  • Target version set to v16.0.0
  • Source set to Development
  • Backport set to octopus,nautilus

#4 Updated by Patrick Donnelly 5 months ago

  • Status changed from Fix Under Review to Pending Backport

#5 Updated by Nathan Cutler 5 months ago

  • Copied to Backport #47252: nautilus: mds: fix possible crash when the MDS is stopping added

#6 Updated by Nathan Cutler 5 months ago

  • Copied to Backport #47253: octopus: mds: fix possible crash when the MDS is stopping added

#7 Updated by Nathan Cutler 3 months ago

  • Status changed from Pending Backport to Resolved

While running with --resolve-parent, the script "backport-create-issue" noticed that all backports of this issue are in status "Resolved" or "Rejected".

Also available in: Atom PDF