Project

General

Profile

Bug #47006

mon: required client features adding/removing

Added by Jos Collin 2 months ago. Updated 26 days ago.

Status:
Resolved
Priority:
Low
Assignee:
Category:
Correctness/Safety
Target version:
% Done:

0%

Source:
Community (dev)
Tags:
Backport:
Regression:
No
Severity:
3 - minor
Reviewed:
Affected Versions:
ceph-qa-suite:
Component(FS):
Labels (FS):
Pull request ID:
Crash signature:

Description

https://docs.ceph.com/docs/master/cephfs/administration/#minimum-client-version

fs required_client_features <fs name> add reply_encoding
fs required_client_features <fs name> rm reply_encoding

It is possible to add an already existing feature to a filesystem and remove a feature that doesn't exist in a filesystem? We need to add a check in FSCommands.cc

History

#1 Updated by Patrick Donnelly 2 months ago

  • Status changed from New to Need More Info

Can you elaborate on what the problem is? Give an example.

#2 Updated by Jos Collin 2 months ago

  • Status changed from Need More Info to New

Patrick Donnelly wrote:

Can you elaborate on what the problem is? Give an example.

jcollin@smithi046:~/ceph/build$ ./bin/ceph fs dump| grep required_client_features
dumped fsmap epoch 12
required_client_features    {}
jcollin@smithi046:~/ceph/build$ ./bin/ceph fs required_client_features a rm reply_encoding
removed feature 'reply_encoding' to required_client_features
jcollin@smithi046:~/ceph/build$ ./bin/ceph fs required_client_features a rm reply_encoding
removed feature 'reply_encoding' to required_client_features
jcollin@smithi046:~/ceph/build$ ./bin/ceph fs dump| grep required_client_features
dumped fsmap epoch 14
required_client_features    {}

The same when using add command too. Is this intentional?

#3 Updated by Patrick Donnelly 2 months ago

Jos Collin wrote:

Patrick Donnelly wrote:

Can you elaborate on what the problem is? Give an example.

[...]

The same when using add command too. Is this intentional?

Well, the command is idempotent. The message could be improved to say that the feature was not set. The exit code should still be 0.

#4 Updated by Patrick Donnelly 2 months ago

  • Status changed from New to Triaged
  • Assignee set to Jos Collin
  • Target version set to v16.0.0

#5 Updated by Jos Collin about 1 month ago

  • Status changed from Triaged to Fix Under Review
  • Pull request ID set to 37359

#6 Updated by Patrick Donnelly 26 days ago

  • Status changed from Fix Under Review to Resolved

Also available in: Atom PDF