Project

General

Profile

Bug #46903

mgr/dashboard: Datatable catches select events from other datatables

Added by Volker Theile 5 months ago. Updated about 2 months ago.

Status:
Resolved
Priority:
Normal
Assignee:
Category:
dashboard/UI
Target version:
% Done:

0%

Source:
Development
Tags:
Backport:
nautilus, octopus
Regression:
No
Severity:
3 - minor
Reviewed:
Affected Versions:
ceph-qa-suite:
Pull request ID:
Crash signature:

Description

Double-clicking in the limit or search action field of an embeded datatable will be processed by the wrapping datatable.

screenshot.gif View (148 KB) Volker Theile, 08/11/2020 01:45 PM

screenshot2.gif View (366 KB) Volker Theile, 08/11/2020 01:48 PM

screenshot3.gif View (975 KB) Volker Theile, 08/12/2020 01:39 PM


Related issues

Precedes mgr - Bug #47175: mgr/dashboard: Fix stale table actions Resolved
Copied to mgr - Backport #47198: nautilus: mgr/dashboard: Datatable catches select events from other datatables Resolved
Copied to mgr - Backport #47199: octopus: mgr/dashboard: Datatable catches select events from other datatables Resolved

History

#1 Updated by Volker Theile 5 months ago

#2 Updated by Volker Theile 5 months ago

  • Subject changed from mgr/dashboard: Datatable catches select events from other datatables to mgr/dashboard: Datatable catches click events from other datatables

#3 Updated by Volker Theile 5 months ago

  • Description updated (diff)

#4 Updated by Volker Theile 5 months ago

#5 Updated by Volker Theile 5 months ago

Seems to be a known problem if the Swimlane datatable, see https://github.com/swimlane/ngx-datatable/issues/899.

#6 Updated by Volker Theile 5 months ago

  • Subject changed from mgr/dashboard: Datatable catches click events from other datatables to mgr/dashboard: Datatable catches select events from other datatables

#7 Updated by Volker Theile 5 months ago

  • Status changed from New to Fix Under Review
  • Pull request ID set to 36590

#8 Updated by Lenz Grimmer 5 months ago

  • Status changed from Fix Under Review to Pending Backport

#9 Updated by Tiago Melo 5 months ago

This introduced a regression in master.
All backports should include https://tracker.ceph.com/issues/47175

#10 Updated by Volker Theile 5 months ago

  • Precedes Bug #47175: mgr/dashboard: Fix stale table actions added

#11 Updated by Nathan Cutler 5 months ago

  • Copied to Backport #47198: nautilus: mgr/dashboard: Datatable catches select events from other datatables added

#12 Updated by Nathan Cutler 5 months ago

  • Copied to Backport #47199: octopus: mgr/dashboard: Datatable catches select events from other datatables added

#13 Updated by Nathan Cutler about 2 months ago

  • Status changed from Pending Backport to Resolved

While running with --resolve-parent, the script "backport-create-issue" noticed that all backports of this issue are in status "Resolved" or "Rejected".

Also available in: Atom PDF