Project

General

Profile

Bug #46886

upgrade/nautilus-x-master: bluefs mount failed to replay log: (14) Bad address during upgrade

Added by Neha Ojha 8 months ago. Updated 7 months ago.

Status:
Resolved
Priority:
Urgent
Assignee:
Target version:
-
% Done:

0%

Source:
Tags:
Backport:
Regression:
No
Severity:
3 - minor
Reviewed:
Affected Versions:
ceph-qa-suite:
Pull request ID:
Crash signature (v1):
Crash signature (v2):

Description

2020-08-06T19:31:02.955+0000 7f8e8b718d80 10 AvlAllocator init_add_free offset 0xacccc0000 length 0xe6670000
2020-08-06T19:31:02.955+0000 7f8e8b718d80 20 bluefs _replay 0x0:  op_file_update  file(ino 17 size 0x1356 mtime 2020-08-06T19:21:37.978506+0000 allocated 10000 extents [1:0xacd0c0000~10000])
2020-08-06T19:31:02.955+0000 7f8e8b718d80 -1 bluefs _check_new_allocations invalid extent 1: 0x6810000~10000: wasn't given but allocated for ino 1
2020-08-06T19:31:02.955+0000 7f8e8b718d80 -1 bluefs mount failed to replay log: (14) Bad address
2020-08-06T19:31:02.955+0000 7f8e8b718d80 20 bluefs _stop_alloc
2020-08-06T19:31:02.955+0000 7f8e8b718d80 -1 bluestore(/var/lib/ceph/osd/ceph-0) _open_bluefs failed bluefs mount: (14) Bad address
2020-08-06T19:31:02.955+0000 7f8e8b718d80 10 bluefs maybe_verify_layout no memorized_layout in bluefs superblock
2020-08-06T19:31:02.955+0000 7f8e8b718d80 -1 bluestore(/var/lib/ceph/osd/ceph-0) _open_db failed to prepare db environment:
2020-08-06T19:31:02.955+0000 7f8e8b718d80  1 bdev(0x55be8b93c000 /var/lib/ceph/osd/ceph-0/block) close
2020-08-06T19:31:03.259+0000 7f8e8b718d80 -1 osd.0 0 OSD:init: unable to mount object store
2020-08-06T19:31:03.259+0000 7f8e8b718d80 -1 ^[[0;31m ** ERROR: osd init failed: (5) Input/output error^[[0m

/a/teuthology-2020-08-06_18:39:39-upgrade:nautilus-x-wip-yuri7-testing-2020-08-06-1716-master-distro-basic-smithi/5292923
/a/kchai-2020-08-09_03:30:55-rados-wip-kefu-testing-2020-08-08-1822-distro-basic-smithi/5323428

Most likely caused by https://github.com/ceph/ceph/pull/30838


Related issues

Duplicated by CephFS - Bug #47051: fs/upgrade/volume_client: Command failed with status 124: 'sudo adjust-ulimits ceph-coverage /home/ubuntu/cephtest/archive/coverage timeout 120 ceph --cluster ceph --log-early osd dump --format=json' Duplicate

History

#2 Updated by Kefu Chai 8 months ago

  • Assignee set to Igor Fedotov

Hi Igor, could you take a look?

#3 Updated by Igor Fedotov 8 months ago

Kefu Chai wrote:

Hi Igor, could you take a look?

Hi Kefu,
yeah, looking...

#4 Updated by Igor Fedotov 8 months ago

  • Status changed from New to Fix Under Review
  • Pull request ID set to 36745

#5 Updated by Patrick Donnelly 8 months ago

  • Duplicated by Bug #47051: fs/upgrade/volume_client: Command failed with status 124: 'sudo adjust-ulimits ceph-coverage /home/ubuntu/cephtest/archive/coverage timeout 120 ceph --cluster ceph --log-early osd dump --format=json' added

#6 Updated by Brad Hubbard 8 months ago

/a/bhubbard-2020-08-26_21:27:35-upgrade:nautilus-x-wip-badone-testing-2-distro-basic-smithi/5378823

#7 Updated by Neha Ojha 7 months ago

  • Subject changed from bluefs mount failed to replay log: (14) Bad address during upgrade to upgrade/nautilus-x-master: bluefs mount failed to replay log: (14) Bad address during upgrade

#8 Updated by Kefu Chai 7 months ago

  • Status changed from Fix Under Review to Resolved

Also available in: Atom PDF