Project

General

Profile

Bug #46875

make check: run-rbd-unit-tests: TestLibRBD.TestPendingAio: test_librbd.cc:4539: Failure

Added by Sebastian Wagner 4 months ago. Updated 24 days ago.

Status:
New
Priority:
Normal
Target version:
-
% Done:

0%

Source:
Q/A
Tags:
Backport:
Regression:
No
Severity:
3 - minor
Reviewed:
Affected Versions:
ceph-qa-suite:
Pull request ID:
Crash signature:

Description

[ RUN      ] TestLibRBD.TestPendingAio
using new format!
/home/jenkins-build/build/workspace/ceph-pull-requests/src/test/librbd/test_librbd.cc:4539: Failure
Expected equality of these values:
  1
  rbd_aio_is_complete(comps[i])
    Which is: 0
[  FAILED  ] TestLibRBD.TestPendingAio (68 ms)

https://jenkins.ceph.com/job/ceph-pull-requests/57209/consoleFull#-361705261e840cee4-f4a4-4183-81dd-42855615f2c1


Related issues

Copied to rbd - Backport #48081: nautilus: make check: run-rbd-unit-tests: TestLibRBD.TestPendingAio: test_librbd.cc:4539: Failure Rejected
Copied to rbd - Backport #48082: octopus: make check: run-rbd-unit-tests: TestLibRBD.TestPendingAio: test_librbd.cc:4539: Failure Rejected

History

#1 Updated by Jason Dillaman 3 months ago

  • Status changed from New to In Progress
  • Assignee set to Jason Dillaman

#2 Updated by Jason Dillaman 3 months ago

  • Status changed from In Progress to Fix Under Review
  • Pull request ID set to 36839

#3 Updated by Mykola Golub 3 months ago

  • Status changed from Fix Under Review to Resolved

#4 Updated by Josh Durgin 25 days ago

  • Status changed from Resolved to Pending Backport
  • Backport set to octopus, nautilus

Looks like this could use a backport - seen in nautilus here:
https://jenkins.ceph.com/job/ceph-pull-requests/62883/
https://github.com/ceph/ceph/pull/37872

[ RUN      ] TestLibRBD.TestPendingAio
using new format!
/home/jenkins-build/build/workspace/ceph-pull-requests/src/test/librbd/test_librbd.cc:4572: Failure
Expected equality of these values:
  1
  rbd_aio_is_complete(comps[i])
    Which is: 0
[  FAILED  ] TestLibRBD.TestPendingAio (96 ms)

#5 Updated by Nathan Cutler 25 days ago

  • Copied to Backport #48081: nautilus: make check: run-rbd-unit-tests: TestLibRBD.TestPendingAio: test_librbd.cc:4539: Failure added

#6 Updated by Nathan Cutler 25 days ago

  • Copied to Backport #48082: octopus: make check: run-rbd-unit-tests: TestLibRBD.TestPendingAio: test_librbd.cc:4539: Failure added

#7 Updated by Jason Dillaman 24 days ago

  • Status changed from Pending Backport to New
  • Backport deleted (octopus, nautilus)

#8 Updated by Nathan Cutler 24 days ago

Thanks, Jason. The "make check" console log that Josh mentioned in Comment 4 (reproduced with a small correction below) has been preserved here: https://gist.github.com/smithfarm/d52b01f1214b723b46013cd9cd8ff497

#9 Updated by Nathan Cutler 24 days ago

Josh Durgin wrote:

Looks like this could use a backport - seen in nautilus master here:
https://jenkins.ceph.com/job/ceph-pull-requests/62883/
https://github.com/ceph/ceph/pull/37872

[...]

Also available in: Atom PDF