Project

General

Profile

Bug #46623

mgr/dashboard: ui/navigation.e2e-spec.ts: AssertionError: Timed out retrying: Expected not to find content: 'Creating...' but continuously found it.

Added by Sebastian Wagner 2 months ago. Updated about 2 months ago.

Status:
Resolved
Priority:
Normal
Assignee:
Category:
dashboard/qa
Target version:
-
% Done:

0%

Source:
Tags:
Backport:
Regression:
No
Severity:
3 - minor
Reviewed:
Affected Versions:
ceph-qa-suite:
Pull request ID:
Crash signature:

Description

https://jenkins.ceph.com/job/ceph-dashboard-pull-requests/4980/consoleFull#842358957c212b007-e891-4176-9ee7-2f60eca393b7

────────────────────────────────────────────────────────────────────────────────────────────────────

  Running:  ui/notification.e2e-spec.ts                                                   (21 of 23)
  Estimated: 56 seconds

  Notification page
    1) "before all" hook for "should open notification sidebar" 
    2) "after all" hook for "should open notification sidebar" 

  0 passing (32s)
  2 failing

  1) Notification page
       "before all" hook for "should open notification sidebar":
     AssertionError: Timed out retrying: Expected not to find content: 'Creating...' but continuously found it.

Because this error occurred during a `before all` hook we are skipping the remaining tests in the current suite: `Notification page`
      at PoolPageHelper.PageHelper.navigateEdit (https://slave-ubuntu08.front.sepia.ceph.com:41082/__cypress/tests?p=cypress/integration/ui/notification.e2e-spec.ts:57:36)
      at PoolPageHelper.edit_pool_pg (https://slave-ubuntu08.front.sepia.ceph.com:41082/__cypress/tests?p=cypress/integration/ui/notification.e2e-spec.ts:286:14)
      at Context.eval (https://slave-ubuntu08.front.sepia.ceph.com:41082/__cypress/tests?p=cypress/integration/ui/notification.e2e-spec.ts:326:15)

  2) Notification page
       "after all" hook for "should open notification sidebar":
     CypressError: `cy.click()` failed because it requires a DOM element.

The subject received was:

  > `undefined`

The previous command that ran was:

  > `cy.get()`

Because this error occurred during a `after all` hook we are skipping the remaining tests in the current suite: `Notification page`
      at ensureElement (https://slave-ubuntu08.front.sepia.ceph.com:41082/__cypress/runner/cypress_runner.js:159721:24)
      at validateType (https://slave-ubuntu08.front.sepia.ceph.com:41082/__cypress/runner/cypress_runner.js:159545:16)
      at Object.ensureSubjectByType (https://slave-ubuntu08.front.sepia.ceph.com:41082/__cypress/runner/cypress_runner.js:159587:11)
      at pushSubjectAndValidate (https://slave-ubuntu08.front.sepia.ceph.com:41082/__cypress/runner/cypress_runner.js:167293:15)
      at Context.<anonymous> (https://slave-ubuntu08.front.sepia.ceph.com:41082/__cypress/runner/cypress_runner.js:167621:18)
  From Your Spec Code:
      at PoolPageHelper.PageHelper.delete (https://slave-ubuntu08.front.sepia.ceph.com:41082/__cypress/tests?p=cypress/integration/ui/notification.e2e-spec.ts:215:50)
      at Context.eval (https://slave-ubuntu08.front.sepia.ceph.com:41082/__cypress/tests?p=cypress/integration/ui/notification.e2e-spec.ts:331:21)

  (Results)

  ┌────────────────────────────────────────────────────────────────────────────────────────────────┐
  │ Tests:        4                                                                                │
  │ Passing:      0                                                                                │
  │ Failing:      1                                                                                │
  │ Pending:      0                                                                                │
  │ Skipped:      3                                                                                │
  │ Screenshots:  2                                                                                │
  │ Video:        false                                                                            │
  │ Duration:     31 seconds                                                                       │
  │ Estimated:    56 seconds                                                                       │
  │ Spec Ran:     ui/notification.e2e-spec.ts                                                      │
  └────────────────────────────────────────────────────────────────────────────────────────────────┘

  (Screenshots)

  -  /home/jenkins-build/build/workspace/ceph-dashboard-pull-requests/src/pybind/mgr/     (1280x720)
     dashboard/frontend/cypress/screenshots/ui/notification.e2e-spec.ts/Notification                
     page -- should open notification sidebar -- before all hook (failed).png                       
  -  /home/jenkins-build/build/workspace/ceph-dashboard-pull-requests/src/pybind/mgr/     (1280x720)
     dashboard/frontend/cypress/screenshots/ui/notification.e2e-spec.ts/Notification                
     page -- should open notification sidebar -- after all hook (failed).png                        

  (Uploading Results)

Related issues

Related to mgr - Bug #46622: mgr/dashboard: e2e test timeouts on configuration.e2e-spec.ts New

History

#1 Updated by Sebastian Wagner 2 months ago

  • Related to Bug #46622: mgr/dashboard: e2e test timeouts on configuration.e2e-spec.ts added

#2 Updated by Tiago Melo 2 months ago

  • Subject changed from ceph-dashboard-pull-requests: ui/navigation.e2e-spec.ts: AssertionError: Timed out retrying: Expected not to find content: 'Creating...' but continuously found it. to mgr/dashboard: ui/navigation.e2e-spec.ts: AssertionError: Timed out retrying: Expected not to find content: 'Creating...' but continuously found it.
  • Category set to dashboard/qa

#4 Updated by Tiago Melo 2 months ago

  • Status changed from New to Fix Under Review
  • Assignee set to Tiago Melo
  • Pull request ID set to 36212

#5 Updated by Tiago Melo about 2 months ago

  • Status changed from Fix Under Review to Resolved

Also available in: Atom PDF