Project

General

Profile

Bug #46560

cephadm: assigns invalid id to daemons

Added by Patrick Donnelly 3 months ago. Updated 3 months ago.

Status:
Resolved
Priority:
High
Category:
-
Target version:
% Done:

0%

Source:
Development
Tags:
Backport:
octopus
Regression:
No
Severity:
3 - minor
Reviewed:
Affected Versions:
ceph-qa-suite:
Pull request ID:
Crash signature:

Description

[root@li718-28 ~]# ceph status
  cluster:
    id:     f7119a0a-c6d6-11ea-9ec2-f23c9286542e
    health: HEALTH_ERR
            Module 'cephadm' has failed: auth get failed: failed to find client.crash.li1003-254 in keyring retval: -2

  services:
    mon: 3 daemons, quorum li718-28.members.linode.com,li983-61,li1003-254 (age 41m)
    mgr: li89-210.svxqkr(active, since 43m)
    mds: cephfs:1 {0=all.li92-60.eikzgq=up:active} 1 up:standby
    osd: 16 osds: 16 up (since 47m), 16 in (since 47m)

  task status:
    scrub status:
        mds.all.li92-60.eikzgq: idle

  data:
    pools:   2 pools, 517 pgs
    objects: 22 objects, 2.2 KiB
    usage:   20 GiB used, 2.4 TiB / 2.4 TiB avail
    pgs:     0.193% pgs not active
             516 active+clean
             1   activating

  progress:
    PG autoscaler decreasing pool 3 PGs from 1024 to 32 (35m)
      [==============..............] (remaining: 31m)

[root@li718-28 ~]# ceph tell mds.all.li92-60.eikzgq help
WARN: "mds.all.li92-60.eikzgq" is not a legal target. it should be one of mon.<id>/osd.<int>/mds.<id>/mgr
target mds.all.li92-60.eikzgq doesn't exists, please pass correct target to tell command, such as mon.a/osd.1/mds.a/mgr

<ID> should not include "." characters?

History

#1 Updated by Sebastian Wagner 3 months ago

  • Status changed from New to Fix Under Review
  • Assignee set to Sebastian Wagner
  • Pull request ID set to 36152

#2 Updated by Kefu Chai 3 months ago

  • Status changed from Fix Under Review to Pending Backport

#3 Updated by Sebastian Wagner 3 months ago

  • Status changed from Pending Backport to Resolved
  • Target version changed from v16.0.0 to v15.2.5

Also available in: Atom PDF