Project

General

Profile

Bug #46497

cephadm: prevent colon character for service_ids.

Added by Sebastian Wagner 9 months ago. Updated 21 days ago.

Status:
Resolved
Priority:
Normal
Assignee:
Category:
cephadm
Target version:
-
% Done:

0%

Source:
Community (user)
Tags:
low-hanging-fruit
Backport:
pacific
Regression:
No
Severity:
3 - minor
Reviewed:
Affected Versions:
ceph-qa-suite:
Pull request ID:
Crash signature (v1):
Crash signature (v2):

Description

https://lists.ceph.io/hyperkitty/list/ceph-users@ceph.io/thread/LL7N4K5RBG2E7P7MDTVC66U2ZHODJEFA/

Hello. I'm trying to upgrade to ceph 15.2.4 from 15.2.3. The upgrade is
almost finished, but it has entered in a service start/stop loop. I'm using
a container deployment over Debian 10 with 4 nodes. The problem is with a
service named literally "mds.label:mds". It has the colon character, which
is of special use in docker. This character can't appear in the name of the
container and also breaks the volumen binding syntax.

History

#1 Updated by Sebastian Wagner 9 months ago

  • Tags set to low-hanging-fruit

#2 Updated by Sebastian Wagner 28 days ago

  • Status changed from New to Fix Under Review
  • Assignee set to Melissa Li

#3 Updated by Sage Weil 23 days ago

  • Status changed from Fix Under Review to Pending Backport
  • Backport set to pacific

#4 Updated by Sage Weil 21 days ago

  • Status changed from Pending Backport to Resolved

Also available in: Atom PDF