Project

General

Profile

Bug #4647

libceph: kill osd request r_con_filling_msg field

Added by Alex Elder over 6 years ago. Updated over 6 years ago.

Status:
Resolved
Priority:
Normal
Assignee:
Category:
-
Target version:
Start date:
04/04/2013
Due date:
% Done:

0%

Source:
Development
Tags:
Backport:
Regression:
No
Severity:
3 - minor
Reviewed:
Affected Versions:
ceph-qa-suite:
Pull request ID:
Crash signature:

Description

This field was (I think) needed at one time to avoid
a race between a request with a response message
getting released and a connection the message was
associated with going away.

It is no longer needed though, and it adds a little
weirdness to the code (an optimization in how to
handle it more efficiently), so get rid of it.

History

#1 Updated by Alex Elder over 6 years ago

  • Target version set to v0.62a

By the way, I'm calling this a bug because "cleanup"
doesn't allow me to mark things as "Need Review"
(or something like that).

#2 Updated by Alex Elder over 6 years ago

  • Status changed from In Progress to Need Review

The following patch has been posted for review:

[PATCH 2/9] libceph: drop ceph_osd_request->r_con_filling_msg

#3 Updated by Alex Elder over 6 years ago

  • Status changed from Need Review to Resolved

The following has been committed to the ceph-client
"testing" repository:

ebc6540 libceph: drop ceph_osd_request->r_con_filling_msg

Also available in: Atom PDF