Project

General

Profile

Bug #46329

cephadm: Dashboard's ganesha option is not correct if there are multiple NFS daemons

Added by Kiefer Chang about 1 month ago. Updated 22 days ago.

Status:
Resolved
Priority:
Normal
Assignee:
Category:
-
Target version:
% Done:

0%

Source:
Tags:
Backport:
octopus
Regression:
No
Severity:
3 - minor
Reviewed:
Affected Versions:
ceph-qa-suite:
Pull request ID:
Crash signature:

Description

How to reproduce:
  • Create an NFS service with multiple daemons. e.g. With the following spec:
    service_type: nfs
    service_id: sesdev_nfs_deployment
    placement:
        count=2
    spec:
        pool: rbd
        namespace: nfs
    
  • The Dashboard NFS page displays the following information and can't be used.

The root cause is the cephadm set duplicate locations:

# ceph dashboard get-ganesha-clusters-rados-pool-namespace
sesdev_nfs_deployment:rbd/nfs,sesdev_nfs_deployment:rbd/nfs

nfs-warning.png View (21.8 KB) Kiefer Chang, 07/02/2020 08:05 AM

History

#1 Updated by Kiefer Chang about 1 month ago

  • Status changed from New to Fix Under Review
  • Pull request ID set to 35908

#2 Updated by Kefu Chai about 1 month ago

  • Status changed from Fix Under Review to Pending Backport

#3 Updated by Kiefer Chang 24 days ago

The backport is included in https://github.com/ceph/ceph/pull/36109

#4 Updated by Sebastian Wagner 22 days ago

  • Status changed from Pending Backport to Resolved
  • Target version set to v15.2.5

Also available in: Atom PDF