Project

General

Profile

Bug #46267

unittest_lockdep failure

Added by Vladimir Bashkirtsev 3 months ago. Updated 2 months ago.

Status:
Resolved
Priority:
Normal
Assignee:
Category:
qa
Target version:
% Done:

0%

Source:
Community (user)
Tags:
Backport:
octopus
Regression:
No
Severity:
3 - minor
Reviewed:
Affected Versions:
ceph-qa-suite:
Pull request ID:
Crash signature:

Description

Apparently during refactoring to use gtest unittest_lockdep was broken. In file src/test/common/test_lockdep.cc I can see

#ifdef CEPH_DEBUG_MUTEX

which now causes test to skip if CEPH_DEBUG_MUTEX is set. However it should be otherwise: if CEPH_DEBUG_MUTEX is NOT set skip the test. And in Ceph 14 this statement reads:

#ifndef CEPH_DEBUG_MUTEX

Adding missing "n" fixes the test and gets expected behaviour.


Related issues

Copied to Ceph - Backport #46307: octopus: unittest_lockdep failure Resolved

History

#1 Updated by Nathan Cutler 3 months ago

  • Assignee set to Kefu Chai

Looks like a regression caused by 2dc50b5f91476cf10429dbcdd52b00e32f599d5c

Kefu?

#2 Updated by Kefu Chai 3 months ago

  • Status changed from New to Fix Under Review
  • Backport set to octopus, nautilus
  • Pull request ID set to 35856

#3 Updated by Kefu Chai 3 months ago

  • Backport changed from octopus, nautilus to octopus

#4 Updated by Kefu Chai 3 months ago

  • Status changed from Fix Under Review to Pending Backport

#5 Updated by Nathan Cutler 3 months ago

#6 Updated by Nathan Cutler 2 months ago

  • Status changed from Pending Backport to Resolved

While running with --resolve-parent, the script "backport-create-issue" noticed that all backports of this issue are in status "Resolved" or "Rejected".

Also available in: Atom PDF