Project

General

Profile

Bug #46222

Cbt installation task for cosbench fails.

Added by Sridhar Seshasayee over 3 years ago. Updated over 3 years ago.

Status:
Won't Fix
Priority:
Normal
Assignee:
-
Category:
-
Target version:
-
% Done:

0%

Source:
Tags:
Backport:
Regression:
No
Severity:
3 - minor
Reviewed:
Affected Versions:
ceph-qa-suite:
Component(RADOS):
Pull request ID:
Crash signature (v1):
Crash signature (v2):

Description

/a/sseshasa-2020-06-24_17:46:09-rados-wip-sseshasa-testing-2020-06-24-1858-distro-basic-smithi/5176309

2020-06-24T21:31:13.533 INFO:teuthology.orchestra.run.smithi085.stdout: creating: cosbench-0.4.2.c3.1/0.4.2.c3/work/Standalone/0.0.0.0/driver/
2020-06-24T21:31:13.534 INFO:teuthology.orchestra.run.smithi085:> cd /home/ubuntu/cephtest && ln -s cosbench-0.4.2.c3.1 cos
2020-06-24T21:31:13.541 INFO:teuthology.orchestra.run.smithi085:> cd /home/ubuntu/cephtest/cos && chmod +x .sh
2020-06-24T21:31:13.590 INFO:teuthology.orchestra.run.smithi085.stderr:chmod: cannot access '
.sh': No such file or directory
2020-06-24T21:31:13.591 DEBUG:teuthology.orchestra.run:got remote process result: 1
2020-06-24T21:31:13.591 ERROR:teuthology.run_tasks:Saw exception from tasks.
Traceback (most recent call last):
File "/home/teuthworker/src/git.ceph.com_git_teuthology_master/teuthology/run_tasks.py", line 93, in run_tasks
manager.__enter__()
File "/home/teuthworker/src/git.ceph.com_git_teuthology_master/teuthology/task/__init__.py", line 122, in enter
self.setup()
File "/home/teuthworker/src/git.ceph.com_ceph-c_wip-sseshasa-testing-2020-06-24-1858/qa/tasks/cbt.py", line 212, in setup
self.install_dependencies()
File "/home/teuthworker/src/git.ceph.com_ceph-c_wip-sseshasa-testing-2020-06-24-1858/qa/tasks/cbt.py", line 153, in install_dependencies
'chmod', '+x', run.Raw('*.sh'),
File "/home/teuthworker/src/git.ceph.com_git_teuthology_master/teuthology/orchestra/remote.py", line 204, in run
r = self._runner(client=self.ssh, name=self.shortname, **kwargs)
File "/home/teuthworker/src/git.ceph.com_git_teuthology_master/teuthology/orchestra/run.py", line 446, in run
r.wait()
File "/home/teuthworker/src/git.ceph.com_git_teuthology_master/teuthology/orchestra/run.py", line 160, in wait
self._raise_for_status()
File "/home/teuthworker/src/git.ceph.com_git_teuthology_master/teuthology/orchestra/run.py", line 182, in _raise_for_status
node=self.hostname, label=self.label
teuthology.exceptions.CommandFailedError: Command failed on smithi085 with status 1: 'cd /home/ubuntu/cephtest/cos && chmod +x *.sh'

History

#1 Updated by Sridhar Seshasayee over 3 years ago

See /a/sseshasa-2020-06-24_17:46:09-rados-wip-sseshasa-testing-2020-06-24-1858-distro-basic-smithi/5176322 as well

#2 Updated by Neha Ojha over 3 years ago

  • Status changed from New to In Progress
  • Pull request ID set to 35683

#4 Updated by Neha Ojha over 3 years ago

  • Status changed from In Progress to Won't Fix

The root cause of this issue is that we put an older version of cosbench in https://drop.ceph.com/qa/ after the recent lab incident. This version did not have the changes required for bionic. We have updated the correct version in https://drop.ceph.com/qa/ and tests are now passing https://pulpito.ceph.com/nojha-2020-06-30_20:44:37-perf-basic-master-distro-basic-smithi/

Also available in: Atom PDF