Project

General

Profile

Bug #46206

cephadm: podman 2.0

Added by Patrick Seidensal 3 months ago. Updated 3 months ago.

Status:
Rejected
Priority:
Normal
Assignee:
-
Category:
cephadm (binary)
Target version:
-
% Done:

0%

Source:
Tags:
Backport:
Regression:
No
Severity:
3 - minor
Reviewed:
Affected Versions:
ceph-qa-suite:
Pull request ID:
Crash signature:

Description

host home ceph-volume inventory failed: cephadm exited with an error code: 1, stderr:INFO:cephadm:/usr/bin/podman:stderr Error: invalid config provided: Groups and privileged are mutually exclusive options
Traceback (most recent call last):
  File \"<stdin>\", line 4846, in <module>
  File \"<stdin>\", line 1089, in _infer_fsid
  File \"<stdin>\", line 1169, in _infer_image
  File \"<stdin>\", line 3060, in command_ceph_volume
  File \"<stdin>\", line 865, in call_throws
RuntimeError: Failed command: /usr/bin/podman run \
     --rm \
     --net=host \
     --ipc=host \
     --privileged \
     --group-add=disk \
     -e CONTAINER_IMAGE=docker.io/ceph/daemon-base:latest-master-devel \
     -e NODE_NAME=home \
     -v /var/run/ceph/e81ab15b-0809-426f-9b98-9ba1dad71877:/var/run/ceph:z \
     -v /var/log/ceph/e81ab15b-0809-426f-9b98-9ba1dad71877:/var/log/ceph:z \
     -v /var/lib/ceph/e81ab15b-0809-426f-9b98-9ba1dad71877/crash:/var/lib/ceph/crash:z \
     -v /dev:/dev \
     -v /run/udev:/run/udev \
     -v /sys:/sys \
     -v /run/lvm:/run/lvm \
     -v /run/lock/lvm:/run/lock/lvm \
     --entrypoint /usr/sbin/ceph-volume docker.io/ceph/daemon-base:latest-master-devel inventory \
     --format=json

podman version 2.0.0


Related issues

Related to Orchestrator - Bug #46429: cephadm fails bootstrap with new Podman Versions 2.0.1 and 2.0.2 Closed

History

#2 Updated by Sebastian Wagner 3 months ago

  • Subject changed from starting up cephadm using vstart fails with podman error to cephadm: podman 2.0
  • Category changed from orchestrator to cephadm (binary)

looks like cephadm is not podman 2.0 compatible

#3 Updated by Patrick Seidensal 3 months ago

Removing changes from commit b5e5c753 would also resolve that issue. I'm not sure though, if that wouldn't introduce another issue.

#4 Updated by Patrick Seidensal 3 months ago

  • Status changed from New to Rejected

This was a bug in Podman v2.0.0 and has been fixed in Podman v2.0.1.

Fixed a bug where the --privileged flag had mistakenly been marked as conflicting with --group-add and --security-opt.

-- https://github.com/containers/libpod/releases/tag/v2.0.1

#5 Updated by Sebastian Wagner about 2 months ago

  • Related to Bug #46429: cephadm fails bootstrap with new Podman Versions 2.0.1 and 2.0.2 added

Also available in: Atom PDF