Project

General

Profile

Bug #46103

Restart service command restarts all the services and accepts service type too

Added by Varsha Rao 7 months ago. Updated 6 months ago.

Status:
Duplicate
Priority:
Normal
Assignee:
-
Category:
orchestrator
Target version:
% Done:

0%

Source:
Development
Tags:
Backport:
Regression:
No
Severity:
3 - minor
Reviewed:
Affected Versions:
ceph-qa-suite:
Pull request ID:
Crash signature:

Description

[root@varsha build]# ./bin/ceph orch ls
NAME                RUNNING  REFRESHED  AGE  PLACEMENT  IMAGE NAME                                      IMAGE ID      
crash                   1/1  2m ago     8m   *          docker.io/ceph/daemon-base:latest-master-devel  c68a24748944  
mds.a                   0/2  2m ago     8m   count:2    docker.io/ceph/daemon-base:latest-master-devel  <unknown>     
nfs.ganesha-vstart      1/1  2m ago     7m   count:1    docker.io/ceph/daemon-base:latest-master-devel  <unknown>     

[root@varsha build]# ./bin/ceph orch restart nfs.ganesha-vstart
restart nfs.ganesha-vstart.varsha from host 'varsha'

[root@varsha build]# ./bin/ceph orch ls
NAME                RUNNING  REFRESHED  AGE  PLACEMENT  IMAGE NAME                                      IMAGE ID      
crash                   1/1  1s ago     9m   *          docker.io/ceph/daemon-base:latest-master-devel  c68a24748944  
mds.a                   0/2  1s ago     9m   count:2    docker.io/ceph/daemon-base:latest-master-devel  <unknown>     
nfs.ganesha-vstart      1/1  1s ago     7m   count:1    docker.io/ceph/daemon-base:latest-master-devel  <unknown>     

Related issues

Related to Orchestrator - Bug #46740: mgr/cephadm: restart of daemon reports host is empty Resolved

History

#1 Updated by Sebastian Wagner 7 months ago

I think this is actually the correct behavior!

#2 Updated by Varsha Rao 7 months ago

Sebastian Wagner wrote:

I think this is actually the correct behavior!

How is it the correct behaviour? If it is then why do we have to specify service name?

#3 Updated by Sebastian Wagner 6 months ago

REFRESHED doesn't mean the daemon was restarted. Just that the status was refreshed

#4 Updated by Sebastian Wagner 6 months ago

  • Status changed from New to Need More Info

#5 Updated by Varsha Rao 6 months ago

Sebastian Wagner wrote:

REFRESHED doesn't mean the daemon was restarted. Just that the status was refreshed

It would be good to mention about it in the doc. Again why are we refreshing status of all the daemons instead of specified service?

#6 Updated by Varsha Rao 6 months ago

Another confusing aspect is it accepts both service type and service name. Is this also intended?

[root@varsha build]# ./bin/ceph orch ps
NAME                       HOST    STATUS          REFRESHED  AGE   VERSION                  IMAGE NAME                                                                                          IMAGE ID      CONTAINER ID  
crash.varsha               varsha  running (2m)    108s ago   2m    16.0.0-3888-g4ba83be982  docker.io/ceph/daemon-base@sha256:f66e162c556668e222aeaa0a99dc1fc409f768bdcf79dc64d1cd4f2217cee902  8c4dd342d02e  b4b47d25ee42  
mds.a.varsha.oqgvks        varsha  unknown         108s ago   113s  <unknown>                docker.io/ceph/daemon-base@sha256:f66e162c556668e222aeaa0a99dc1fc409f768bdcf79dc64d1cd4f2217cee902  <unknown>     <unknown>     
nfs.ganesha-vstart.varsha  varsha  running (109s)  108s ago   110s  3.3                      docker.io/ceph/daemon-base@sha256:f66e162c556668e222aeaa0a99dc1fc409f768bdcf79dc64d1cd4f2217cee902  8c4dd342d02e  d60391dab881  
[root@varsha build]# ./bin/ceph orch restart nfs
restart nfs.ganesha-vstart.varsha from host 'varsha'
[root@varsha build]# ./bin/ceph orch restart nfs.ganesha-vstart
restart nfs.ganesha-vstart.varsha from host 'varsha'
[root@varsha build]# ./bin/ceph orch ps
NAME                       HOST    STATUS        REFRESHED  AGE  VERSION                  IMAGE NAME                                                                                          IMAGE ID      CONTAINER ID  
crash.varsha               varsha  running (3m)  39s ago    3m   16.0.0-3888-g4ba83be982  docker.io/ceph/daemon-base@sha256:f66e162c556668e222aeaa0a99dc1fc409f768bdcf79dc64d1cd4f2217cee902  8c4dd342d02e  b4b47d25ee42  
mds.a.varsha.oqgvks        varsha  error         39s ago    2m   <unknown>                docker.io/ceph/daemon-base@sha256:f66e162c556668e222aeaa0a99dc1fc409f768bdcf79dc64d1cd4f2217cee902  <unknown>     <unknown>     
nfs.ganesha-vstart.varsha  varsha  running (2m)  39s ago    2m   3.3                      docker.io/ceph/daemon-base@sha256:f66e162c556668e222aeaa0a99dc1fc409f768bdcf79dc64d1cd4f2217cee902  8c4dd342d02e  d60391dab881                                                                                         

It would be nice to clarify that service_name means service_type+service_id

#7 Updated by Varsha Rao 6 months ago

  • Subject changed from Restart service command restarts all the services to Restart service command restarts all the services and accepts service type too
  • Status changed from Need More Info to New

#8 Updated by Varsha Rao 6 months ago

Actually the restart command fails.

[root@varsha build]# ./bin/ceph orch restart nfs.ganesha-vstart
restart nfs.ganesha-vstart.varsha from host 'varsha'

mgr log

2020-07-29T17:03:09.824+0530 7ff571895700  0 log_channel(cephadm) log [INF] : Restart service nfs.ganesha-vstart
2020-07-29T17:03:09.824+0530 7ff56e08e700  0 [cephadm ERROR root] host address is empty
Traceback (most recent call last):
  File "/home/varsha/ceph/src/pybind/mgr/cephadm/module.py", line 1014, in _remote_connection
    raise OrchestratorError("host address is empty")
orchestrator._interface.OrchestratorError: host address is empty
2020-07-29T17:03:09.825+0530 7ff56e08e700 20 log_channel(cephadm) update_config log_to_monitors {default=true} log_to_syslog {default=false} log_channels {audit=local0,default=daemon} log_prios {default=info}
2020-07-29T17:03:09.825+0530 7ff56e08e700 10 log_channel(cephadm) update_config to_monitors: true to_syslog: false syslog_facility: daemon prio: info to_graylog: false graylog_host: 127.0.0.1 graylog_port: 12201)
2020-07-29T17:03:09.825+0530 7ff56e08e700 -1 log_channel(cephadm) log [ERR] : host address is empty
Traceback (most recent call last):
  File "/home/varsha/ceph/src/pybind/mgr/cephadm/module.py", line 1014, in _remote_connection
    raise OrchestratorError("host address is empty")
orchestrator._interface.OrchestratorError: host address is empty
2020-07-29T17:03:09.825+0530 7ff56e08e700  0 [cephadm ERROR root] `varsha: cephadm unit nfs.ganesha-vstart.varsha reset-failed` failed
Traceback (most recent call last):
  File "/home/varsha/ceph/src/pybind/mgr/cephadm/module.py", line 1573, in _daemon_action
    out, err, code = self._run_cephadm(
  File "/home/varsha/ceph/src/pybind/mgr/cephadm/module.py", line 1060, in _run_cephadm
    with self._remote_connection(host, addr) as tpl:
  File "/usr/lib64/python3.8/contextlib.py", line 113, in __enter__
    return next(self.gen)
  File "/home/varsha/ceph/src/pybind/mgr/cephadm/module.py", line 1014, in _remote_connection
    raise OrchestratorError("host address is empty")
orchestrator._interface.OrchestratorError: host address is empty

#9 Updated by Sebastian Wagner 6 months ago

  • Description updated (diff)

#10 Updated by Sebastian Wagner 6 months ago

  • Related to Bug #46740: mgr/cephadm: restart of daemon reports host is empty added

#11 Updated by Sebastian Wagner 6 months ago

  • Status changed from New to Duplicate

Also available in: Atom PDF