Project

General

Profile

Bug #46045

qa/tasks/cephadm: Module 'dashboard' is not enabled error

Added by Varsha Rao 3 months ago. Updated about 1 month ago.

Status:
Resolved
Priority:
Normal
Assignee:
Category:
cephadm
Target version:
% Done:

0%

Source:
Development
Tags:
Backport:
octopus
Regression:
No
Severity:
3 - minor
Reviewed:
Affected Versions:
ceph-qa-suite:
Pull request ID:
Crash signature:

Description

http://qa-proxy.ceph.com/teuthology/kchai-2020-06-17_08:41:50-rados-wip-kefu-testing-2020-06-17-1349-distro-basic-smithi/5157584/teuthology.log

2020-06-17T09:00:38.033 INFO:ceph.mon.a.smithi167.stdout:Jun 17 09:00:37 smithi167 bash[15800]: audit 2020-06-17T09:00:36.455531+0000 mgr.a (mgr.14245) 66 : audit [DBG] from='mon.0 -' entity='mon.' cmd=[{"prefix": "dashboard get-ganesha-c
lusters-rados-pool-namespace"}]: dispatch
2020-06-17T09:00:38.033 INFO:ceph.mon.a.smithi167.stdout:Jun 17 09:00:37 smithi167 bash[15800]: cephadm 2020-06-17T09:00:36.655624+0000 mgr.a (mgr.14245) 67 : cephadm [WRN] Failed to get Dashboard config for Ganesha: dashboard get-ganesha
-clusters-rados-pool-namespace failed: Module 'dashboard' is not enabled (required by command 'dashboard get-ganesha-clusters-rados-pool-namespace'): use `ceph mgr module enable dashboard` to enable it retval: -95

History

#1 Updated by Sebastian Wagner about 2 months ago

  • Status changed from New to Need More Info

this was due to the fact that the FS tests don't enable the dashboard?

#2 Updated by Varsha Rao about 2 months ago

  • Status changed from Need More Info to New

Sebastian Wagner wrote:

this was due to the fact that the FS tests don't enable the dashboard?

Yes, even other tests such as prometheus1 also don't enable dashboard. These tests were written prior setting dashboard namespace config2 got merged. As per discussion with Kiefer, we decided it would be best to check if dashboard is enabled before trying to set this config option.

[1] https://github.com/ceph/ceph/blob/720fd5613351f5af912012f50f8c27cad9f9c961/qa/tasks/mgr/test_prometheus.py#L13
[2] https://github.com/ceph/ceph/commit/130cadf6e571e8f3559fefa9b3e25b02e20b3d42

#3 Updated by Varsha Rao about 2 months ago

  • Assignee set to Kiefer Chang
  • Backport set to octopus

#4 Updated by Kiefer Chang about 2 months ago

  • Status changed from New to Fix Under Review
  • Pull request ID set to 36386

#5 Updated by Sebastian Wagner about 1 month ago

  • Status changed from Fix Under Review to Resolved
  • Target version changed from v16.0.0 to v15.2.5

Also available in: Atom PDF