Project

General

Profile

Bug #45915

Missing Octopus packages for Ubuntu 20.04 on arm64

Added by Florent Flament 11 months ago. Updated 5 months ago.

Status:
New
Priority:
Normal
Assignee:
-
Category:
-
Target version:
% Done:

0%

Source:
Community (user)
Tags:
Backport:
Regression:
No
Severity:
3 - minor
Reviewed:
06/07/2020
Affected Versions:
ceph-qa-suite:
ceph-ansible
Pull request ID:
Crash signature (v1):
Crash signature (v2):

Description

Hardware: Raspberry Pi 4 (arm64)
Ceph release: Octopus
Repository: community

`ceph-ansible` fails to install `ceph-common` with the following error
message:

```
TASK [ceph-common : install ceph for debian] *****************************************************************************************
Sunday 07 June 2020 18:46:08 +0200 (0:00:00.126) 0:00:52.812 *****
FAILED - RETRYING: install ceph for debian (3 retries left).
FAILED - RETRYING: install ceph for debian (2 retries left).
FAILED - RETRYING: install ceph for debian (1 retries left).
fatal: [cephpi]: FAILED! => changed=false
attempts: 3
cache_update_time: 1591548360
cache_updated: false
msg: |-
'/usr/bin/apt-get y -o "Dpkg::Options::=--force-confdef" -o "Dpkg::Options::=--force-confold" install 'ceph' 'ceph-common'' failed: E: Unable to correct problems, you have held broken packages.
rc: 100
stderr: |

E: Unable to correct problems, you have held broken packages.
stderr_lines: <omitted>
stdout: |-
Reading package lists...
Building dependency tree...
Reading state information...
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
ceph : Depends: ceph-mgr (= 15.2.1-0ubuntu2) but it is not going to be installed
ceph-common : Depends: python3-ceph-argparse (= 15.2.1-0ubuntu2) but 15.2.3-1focal is to be installed
Depends: python3-ceph-common (= 15.2.1-0ubuntu2) but 15.2.3-1focal is to be installed
Depends: python3-cephfs (= 15.2.1-0ubuntu2) but it is not going to be installed
stdout_lines: &lt;omitted&gt;
```

History

#1 Updated by Mathew Clarke 5 months ago

me too .... but with the armhf repo

root@test:/var/lib# sudo apt install ceph
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 ceph : Depends: ceph-mgr (= 15.2.5-0ubuntu0.20.04.1) but it is not going to be installed
        Depends: ceph-mon (= 15.2.5-0ubuntu0.20.04.1) but it is not going to be installed
        Depends: ceph-osd (= 15.2.5-0ubuntu0.20.04.1) but it is not going to be installed
E: Unable to correct problems, you have held broken packages.
root@test:/var/lib# lsb_release -a
No LSB modules are available.
Distributor ID:    Ubuntu
Description:    Ubuntu 20.04.1 LTS
Release:    20.04
Codename:    focal

root@test:/var/lib# cat /etc/apt/sources.list.d/ceph.list 
deb https://download.ceph.com/debian-octopus/ focal main
# deb-src https://download.ceph.com/debian-octopus/ focal main

Also available in: Atom PDF