Project

General

Profile

Bug #45691

nautilus: 'cd /home/ubuntu/cephtest/s3-tests && ./bootstrap' fails

Added by Kefu Chai 2 months ago. Updated 20 days ago.

Status:
Pending Backport
Priority:
Normal
Assignee:
-
Target version:
-
% Done:

0%

Source:
Tags:
Backport:
nautilus octopus
Regression:
No
Severity:
3 - minor
Reviewed:
Affected Versions:
ceph-qa-suite:
rgw
Pull request ID:
Crash signature:

Description

2020-05-24T17:30:10.482 INFO:teuthology.orchestra.run.smithi019:> cd /home/ubuntu/cephtest/s3-tests && ./bootstrap
...
2020-05-24T17:30:10.668 INFO:teuthology.orchestra.run.smithi019.stderr:./bootstrap: missing required DEB packages. Installing via sudo.
...
2020-05-24T17:30:41.670 INFO:teuthology.orchestra.run.smithi019.stdout:  Installing build dependencies: finished with status 'done'
2020-05-24T17:30:41.670 INFO:teuthology.orchestra.run.smithi019.stdout:  Getting requirements to build wheel: started

2020-05-24T17:30:41.807 INFO:teuthology.orchestra.run.smithi019.stderr:ERROR: Exception:
2020-05-24T17:30:41.808 INFO:teuthology.orchestra.run.smithi019.stderr:Traceback (most recent call last):
2020-05-24T17:30:41.808 INFO:teuthology.orchestra.run.smithi019.stderr:  File "/home/ubuntu/cephtest/s3-tests/virtualenv/local/lib/python2.7/site-packages/pip/_internal/cli/base_
command.py", line 188, in _main
2020-05-24T17:30:41.808 INFO:teuthology.orchestra.run.smithi019.stderr:    status = self.run(options, args)
2020-05-24T17:30:41.808 INFO:teuthology.orchestra.run.smithi019.stderr:  File "/home/ubuntu/cephtest/s3-tests/virtualenv/local/lib/python2.7/site-packages/pip/_internal/cli/req_c
ommand.py", line 185, in wrapper
2020-05-24T17:30:41.808 INFO:teuthology.orchestra.run.smithi019.stderr:    return func(self, options, args)
2020-05-24T17:30:41.808 INFO:teuthology.orchestra.run.smithi019.stderr:  File "/home/ubuntu/cephtest/s3-tests/virtualenv/local/lib/python2.7/site-packages/pip/_internal/commands/install.py", line 333, in run
2020-05-24T17:30:41.808 INFO:teuthology.orchestra.run.smithi019.stderr:    reqs, check_supported_wheels=not options.target_dir
2020-05-24T17:30:41.808 INFO:teuthology.orchestra.run.smithi019.stderr:  File "/home/ubuntu/cephtest/s3-tests/virtualenv/local/lib/python2.7/site-packages/pip/_internal/resolution/legacy/resolver.py", line 179, in resolve
2020-05-24T17:30:41.809 INFO:teuthology.orchestra.run.smithi019.stderr:    discovered_reqs.extend(self._resolve_one(requirement_set, req))
2020-05-24T17:30:41.809 INFO:teuthology.orchestra.run.smithi019.stderr:  File "/home/ubuntu/cephtest/s3-tests/virtualenv/local/lib/python2.7/site-packages/pip/_internal/resolution/legacy/resolver.py", line 362, in _resolve_one
2020-05-24T17:30:41.809 INFO:teuthology.orchestra.run.smithi019.stderr:    abstract_dist = self._get_abstract_dist_for(req_to_install)
2020-05-24T17:30:41.809 INFO:teuthology.orchestra.run.smithi019.stderr:  File "/home/ubuntu/cephtest/s3-tests/virtualenv/local/lib/python2.7/site-packages/pip/_internal/resolution/legacy/resolver.py", line 314, in _get_abstract_dist_for
2020-05-24T17:30:41.809 INFO:teuthology.orchestra.run.smithi019.stderr:    abstract_dist = self.preparer.prepare_linked_requirement(req)
2020-05-24T17:30:41.810 INFO:teuthology.orchestra.run.smithi019.stderr:  File "/home/ubuntu/cephtest/s3-tests/virtualenv/local/lib/python2.7/site-packages/pip/_internal/operations/prepare.py", line 488, in prepare_linked_requirement
2020-05-24T17:30:41.810 INFO:teuthology.orchestra.run.smithi019.stderr:    req, self.req_tracker, self.finder, self.build_isolation,
2020-05-24T17:30:41.810 INFO:teuthology.orchestra.run.smithi019.stderr:  File "/home/ubuntu/cephtest/s3-tests/virtualenv/local/lib/python2.7/site-packages/pip/_internal/operations/prepare.py", line 91, in _get_prepared_distribution
2020-05-24T17:30:41.810 INFO:teuthology.orchestra.run.smithi019.stderr:    abstract_dist.prepare_distribution_metadata(finder, build_isolation)
2020-05-24T17:30:41.810 INFO:teuthology.orchestra.run.smithi019.stderr:  File "/home/ubuntu/cephtest/s3-tests/virtualenv/local/lib/python2.7/site-packages/pip/_internal/distributions/sdist.py", line 38, in prepare_distribution_metadata
2020-05-24T17:30:41.810 INFO:teuthology.orchestra.run.smithi019.stderr:    self._setup_isolation(finder)
2020-05-24T17:30:41.811 INFO:teuthology.orchestra.run.smithi019.stderr:  File "/home/ubuntu/cephtest/s3-tests/virtualenv/local/lib/python2.7/site-packages/pip/_internal/distributions/sdist.py", line 96, in _setup_isolation
2020-05-24T17:30:41.811 INFO:teuthology.orchestra.run.smithi019.stderr:    reqs = backend.get_requires_for_build_wheel()
2020-05-24T17:30:41.811 INFO:teuthology.orchestra.run.smithi019.stderr:  File "/home/ubuntu/cephtest/s3-tests/virtualenv/local/lib/python2.7/site-packages/pip/_vendor/pep517/wrappers.py", line 161, in get_requires_for_build_wheel
2020-05-24T17:30:41.811 INFO:teuthology.orchestra.run.smithi019.stderr:    'config_settings': config_settings
2020-05-24T17:30:41.811 INFO:teuthology.orchestra.run.smithi019.stderr:  File "/home/ubuntu/cephtest/s3-tests/virtualenv/local/lib/python2.7/site-packages/pip/_vendor/pep517/wrappers.py", line 265, in _call_hook
2020-05-24T17:30:41.811 INFO:teuthology.orchestra.run.smithi019.stderr:    raise BackendUnavailable(data.get('traceback', ''))

/a/kchai-2020-05-24_17:10:51-rgw-nautilus-distro-basic-smithi/5087644/


Related issues

Copied to rgw-testing - Backport #46537: nautilus: nautilus: 'cd /home/ubuntu/cephtest/s3-tests && ./bootstrap' fails Need More Info
Copied to rgw-testing - Backport #46538: octopus: nautilus: 'cd /home/ubuntu/cephtest/s3-tests && ./bootstrap' fails Need More Info

History

#1 Updated by Kefu Chai 2 months ago

2020-05-24T17:36:39.263 INFO:teuthology.orchestra.run.smithi045:> cd /home/ubuntu/cephtest/ragweed && ./bootstrap
2020-05-24T17:36:45.177 INFO:teuthology.orchestra.run.smithi045.stderr:./bootstrap: missing required RPM packages. Installing via sudo.
2020-05-24T17:36:45.339 INFO:teuthology.orchestra.run.smithi045.stdout:Loaded plugins: fastestmirror, langpacks, priorities
....
2020-05-24T17:37:09.525 INFO:teuthology.orchestra.run.smithi045.stdout:Collecting httplib2
2020-05-24T17:37:09.538 INFO:teuthology.orchestra.run.smithi045.stdout:  Downloading httplib2-0.18.1.tar.gz (262 kB)
2020-05-24T17:37:09.659 INFO:teuthology.orchestra.run.smithi045.stdout:  Installing build dependencies: started
2020-05-24T17:37:11.933 INFO:teuthology.orchestra.run.smithi045.stdout:  Installing build dependencies: finished with status 'done'
2020-05-24T17:37:11.934 INFO:teuthology.orchestra.run.smithi045.stdout:  Getting requirements to build wheel: started
2020-05-24T17:37:12.110 INFO:teuthology.orchestra.run.smithi045.stdout:  Getting requirements to build wheel: finished with status 'done'
2020-05-24T17:37:12.113 INFO:teuthology.orchestra.run.smithi045.stderr:ERROR: Exception:
2020-05-24T17:37:12.113 INFO:teuthology.orchestra.run.smithi045.stderr:Traceback (most recent call last):
2020-05-24T17:37:12.113 INFO:teuthology.orchestra.run.smithi045.stderr:  File "/home/ubuntu/cephtest/ragweed/virtualenv/lib/python2.7/site-packages/pip/_internal/cli/base_command
.py", line 188, in _main
2020-05-24T17:37:12.113 INFO:teuthology.orchestra.run.smithi045.stderr:    status = self.run(options, args)
2020-05-24T17:37:12.114 INFO:teuthology.orchestra.run.smithi045.stderr:  File "/home/ubuntu/cephtest/ragweed/virtualenv/lib/python2.7/site-packages/pip/_internal/cli/req_command.
py", line 185, in wrapper
2020-05-24T17:37:12.114 INFO:teuthology.orchestra.run.smithi045.stderr:    return func(self, options, args)
2020-05-24T17:37:12.114 INFO:teuthology.orchestra.run.smithi045.stderr:  File "/home/ubuntu/cephtest/ragweed/virtualenv/lib/python2.7/site-packages/pip/_internal/commands/install
.py", line 333, in run
2020-05-24T17:37:12.114 INFO:teuthology.orchestra.run.smithi045.stderr:    reqs, check_supported_wheels=not options.target_dir
2020-05-24T17:37:12.114 INFO:teuthology.orchestra.run.smithi045.stderr:  File "/home/ubuntu/cephtest/ragweed/virtualenv/lib/python2.7/site-packages/pip/_internal/resolution/legac
y/resolver.py", line 179, in resolve
2020-05-24T17:37:12.114 INFO:teuthology.orchestra.run.smithi045.stderr:    discovered_reqs.extend(self._resolve_one(requirement_set, req))
2020-05-24T17:37:12.114 INFO:teuthology.orchestra.run.smithi045.stderr:  File "/home/ubuntu/cephtest/ragweed/virtualenv/lib/python2.7/site-packages/pip/_internal/resolution/legac
y/resolver.py", line 362, in _resolve_one
2020-05-24T17:37:12.118 INFO:teuthology.orchestra.run.smithi045.stderr:    abstract_dist = self._get_abstract_dist_for(req_to_install)
2020-05-24T17:37:12.118 INFO:teuthology.orchestra.run.smithi045.stderr:  File "/home/ubuntu/cephtest/ragweed/virtualenv/lib/python2.7/site-packages/pip/_internal/resolution/legac
y/resolver.py", line 314, in _get_abstract_dist_for
2020-05-24T17:37:12.118 INFO:teuthology.orchestra.run.smithi045.stderr:    abstract_dist = self.preparer.prepare_linked_requirement(req)
2020-05-24T17:37:12.119 INFO:teuthology.orchestra.run.smithi045.stderr:  File "/home/ubuntu/cephtest/ragweed/virtualenv/lib/python2.7/site-packages/pip/_internal/operations/prepa
re.py", line 488, in prepare_linked_requirement
2020-05-24T17:37:12.119 INFO:teuthology.orchestra.run.smithi045.stderr:    req, self.req_tracker, self.finder, self.build_isolation,
2020-05-24T17:37:12.119 INFO:teuthology.orchestra.run.smithi045.stderr:  File "/home/ubuntu/cephtest/ragweed/virtualenv/lib/python2.7/site-packages/pip/_internal/operations/prepa
re.py", line 91, in _get_prepared_distribution
2020-05-24T17:37:12.119 INFO:teuthology.orchestra.run.smithi045.stderr:    abstract_dist.prepare_distribution_metadata(finder, build_isolation)
2020-05-24T17:37:12.119 INFO:teuthology.orchestra.run.smithi045.stderr:  File "/home/ubuntu/cephtest/ragweed/virtualenv/lib/python2.7/site-packages/pip/_internal/distributions/sd
ist.py", line 38, in prepare_distribution_metadata
2020-05-24T17:37:12.119 INFO:teuthology.orchestra.run.smithi045.stderr:    self._setup_isolation(finder)
2020-05-24T17:37:12.119 INFO:teuthology.orchestra.run.smithi045.stderr:  File "/home/ubuntu/cephtest/ragweed/virtualenv/lib/python2.7/site-packages/pip/_internal/distributions/sdist.py", line 96, in _setup_isolation
2020-05-24T17:37:12.120 INFO:teuthology.orchestra.run.smithi045.stderr:    reqs = backend.get_requires_for_build_wheel()
2020-05-24T17:37:12.120 INFO:teuthology.orchestra.run.smithi045.stderr:  File "/home/ubuntu/cephtest/ragweed/virtualenv/lib/python2.7/site-packages/pip/_vendor/pep517/wrappers.py", line 161, in get_requires_for_build_wheel
2020-05-24T17:37:12.120 INFO:teuthology.orchestra.run.smithi045.stderr:    'config_settings': config_settings
2020-05-24T17:37:12.120 INFO:teuthology.orchestra.run.smithi045.stderr:  File "/home/ubuntu/cephtest/ragweed/virtualenv/lib/python2.7/site-packages/pip/_vendor/pep517/wrappers.py", line 265, in _call_hook
2020-05-24T17:37:12.120 INFO:teuthology.orchestra.run.smithi045.stderr:    raise BackendUnavailable(data.get('traceback', ''))

2020-05-24T17:37:12.305 ERROR:teuthology.contextutil:Saw exception from nested tasks
Traceback (most recent call last):
  File "/home/teuthworker/src/git.ceph.com_git_teuthology_py2/teuthology/contextutil.py", line 32, in nested
    vars.append(enter())
  File "/usr/lib/python2.7/contextlib.py", line 17, in __enter__
    return self.gen.next()
  File "/home/teuthworker/src/github.com_ceph_ceph_nautilus/qa/tasks/ragweed.py", line 193, in configure
    './bootstrap',
  File "/home/teuthworker/src/git.ceph.com_git_teuthology_py2/teuthology/orchestra/remote.py", line 206, in run
    r = self._runner(client=self.ssh, name=self.shortname, **kwargs)
  File "/home/teuthworker/src/git.ceph.com_git_teuthology_py2/teuthology/orchestra/run.py", line 473, in run
    r.wait()
  File "/home/teuthworker/src/git.ceph.com_git_teuthology_py2/teuthology/orchestra/run.py", line 162, in wait
    self._raise_for_status()
  File "/home/teuthworker/src/git.ceph.com_git_teuthology_py2/teuthology/orchestra/run.py", line 184, in _raise_for_status
    node=self.hostname, label=self.label
CommandFailedError: Command failed on smithi045 with status 2: 'cd /home/ubuntu/cephtest/ragweed && ./bootstrap'

/a//kchai-2020-05-24_17:10:51-rgw-nautilus-distro-basic-smithi/5087646

#2 Updated by Kefu Chai 2 months ago

  • Description updated (diff)

#4 Updated by Kefu Chai 2 months ago

tests using s3-tests now passes, see http://pulpito.ceph.com/kchai-2020-05-25_06:20:22-rgw-nautilus-distro-basic-smithi/5091330/

tested using:

diff --git a/qa/suites/rgw/thrash/workload/rgw_readwrite.yaml b/qa/suites/rgw/thrash/workload/rgw_readwrite.yaml
index d67d526389..4bff2ab56b 100644
--- a/qa/suites/rgw/thrash/workload/rgw_readwrite.yaml
+++ b/qa/suites/rgw/thrash/workload/rgw_readwrite.yaml
@@ -1,7 +1,8 @@
 tasks:
 - s3readwrite:
     client.0:
-      force-branch: ceph-nautilus
+      force-branch: ceph-nautilus-s3test-setuptools
+      git_remote: https://github.com/tchaikov/
       rgw_server: client.0
       readwrite:
         bucket: rwtest

and https://github.com/ceph/s3-tests/pull/349

and backport of https://github.com/ceph/ceph/pull/35226

#6 Updated by Casey Bodley 2 months ago

  • Status changed from New to Resolved

#7 Updated by Casey Bodley 20 days ago

  • Status changed from Resolved to Pending Backport
  • Backport set to nautilus octopus

looks like we need backports

#8 Updated by Nathan Cutler 20 days ago

  • Copied to Backport #46537: nautilus: nautilus: 'cd /home/ubuntu/cephtest/s3-tests && ./bootstrap' fails added

#9 Updated by Nathan Cutler 20 days ago

  • Copied to Backport #46538: octopus: nautilus: 'cd /home/ubuntu/cephtest/s3-tests && ./bootstrap' fails added

#10 Updated by Nathan Cutler 20 days ago

@Casey, I'm guessing this is the fix that needs backporting: https://github.com/ceph/ragweed/pull/8

Can you confirm that? Also, since I have never staged a ragweed backport before, can you confirm that the target branches are the same as for ceph? i.e. "nautilus" branch for nautilus and "octopus" branch for octopus?

Also available in: Atom PDF