Project

General

Profile

Bug #45606

build_incremental_map_msg missing incremental map while snaptrim or backfilling

Added by Bastian Mäuser over 2 years ago. Updated over 2 years ago.

Status:
Resolved
Priority:
Normal
Assignee:
Category:
Correctness/Safety
Target version:
% Done:

0%

Source:
Tags:
low-hanging-fruit
Backport:
octopus, nautilus
Regression:
No
Severity:
4 - irritation
Reviewed:
Affected Versions:
ceph-qa-suite:
rados
Component(RADOS):
Pull request ID:
Crash signature (v1):
Crash signature (v2):

Description

Hello,

I'm not sure if this is an issue or not. On one Cluster I see the following Messages, most times when snaptrim after daily Snapshots are running, but not always:

May 19 06:38:19 px1 ceph-osd515584: 2020-05-19 06:38:19.655 7f76ea959700 -1 osd.7 33087 build_incremental_map_msg missing incremental map 33087
May 19 06:38:19 px1 ceph-osd515584: 2020-05-19 06:38:19.807 7f76ca65b700 -1 osd.7 33087 build_incremental_map_msg missing incremental map 33087
May 19 06:38:20 px1 ceph-osd515584: 2020-05-19 06:38:20.031 7f76cce60700 -1 osd.7 33087 build_incremental_map_msg missing incremental map 33087
May 19 06:38:20 px1 ceph-osd515584: 2020-05-19 06:38:20.031 7f76cce60700 -1 osd.7 33087 build_incremental_map_msg missing incremental map 33087
May 19 06:38:20 px1 ceph-osd515584: 2020-05-19 06:38:20.035 7f76cd661700 -1 osd.7 33087 build_incremental_map_msg missing incremental map 33087
May 19 06:38:20 px1 ceph-osd515584: 2020-05-19 06:38:20.235 7f76c8e58700 -1 osd.7 33087 build_incremental_map_msg missing incremental map 33087
May 19 06:38:20 px1 ceph-osd515584: 2020-05-19 06:38:20.235 7f76c8e58700 -1 osd.7 33087 build_incremental_map_msg missing incremental map 33087
May 19 06:38:20 px1 ceph-osd515584: 2020-05-19 06:38:20.271 7f76c9e5a700 -1 osd.7 33087 build_incremental_map_msg missing incremental map 33087

Is this something I should worry about, or is it just an informational Log Message?


Related issues

Copied to RADOS - Backport #45775: octopus: build_incremental_map_msg missing incremental map while snaptrim or backfilling Resolved
Copied to RADOS - Backport #45776: nautilus: build_incremental_map_msg missing incremental map while snaptrim or backfilling Resolved

History

#1 Updated by Neha Ojha over 2 years ago

  • Tags set to low-hanging-fruit

Nothing to worry about, this message should just be a dout instead.

#2 Updated by Nathan Cutler over 2 years ago

  • Backport set to octopus, nautilus

#3 Updated by Nathan Cutler over 2 years ago

  • Status changed from New to Fix Under Review
  • Assignee set to Nathan Cutler
  • Pull request ID set to 35222

#4 Updated by Kefu Chai over 2 years ago

  • Status changed from Fix Under Review to Pending Backport

#5 Updated by Nathan Cutler over 2 years ago

  • Copied to Backport #45775: octopus: build_incremental_map_msg missing incremental map while snaptrim or backfilling added

#6 Updated by Nathan Cutler over 2 years ago

  • Copied to Backport #45776: nautilus: build_incremental_map_msg missing incremental map while snaptrim or backfilling added

#7 Updated by Nathan Cutler over 2 years ago

  • Status changed from Pending Backport to Resolved

While running with --resolve-parent, the script "backport-create-issue" noticed that all backports of this issue are in status "Resolved" or "Rejected".

Also available in: Atom PDF