Project

General

Profile

Bug #45572

cephadm: ceph-crash isn't deployed anywhere

Added by Tim Serong 7 months ago. Updated 7 months ago.

Status:
Rejected
Priority:
Normal
Assignee:
-
Category:
-
Target version:
-
% Done:

0%

Source:
Tags:
Backport:
octopus
Regression:
No
Severity:
2 - major
Reviewed:
Affected Versions:
ceph-qa-suite:
Pull request ID:
Crash signature:

Description

AFAICT when deploying a containerized cluster with cephadm, ceph-crash is never deployed anywhere. This means that if a daemon crashes and dumps info to /var/lib/ceph/crash, the crash data is saved to disk, but ceph crash stat always prints "0 crashes recorded", because the crashes never actually get posted.

Previously, installing ceph-base would enable the ceph-crash service, but if you're running a cephadm-deployed cluster, you never install that package.

Do we perhaps need to run an additional ceph-crash container on each host?

History

#1 Updated by Tim Serong 7 months ago

Ah. Found it. This is due to ceph-salt calling cephadm bootstrap with --skip-ssh, so presumably actually needs to be dealt with in ceph-salt...

#2 Updated by Tim Serong 7 months ago

  • Status changed from New to Rejected

Also available in: Atom PDF