Project

General

Profile

Bug #45560

cephadm: fail to create OSDs

Added by Kiefer Chang about 2 months ago. Updated about 1 month ago.

Status:
Resolved
Priority:
Urgent
Assignee:
-
Category:
cephadm
Target version:
% Done:

0%

Source:
Tags:
Backport:
Regression:
No
Severity:
3 - minor
Reviewed:
Affected Versions:
ceph-qa-suite:
Pull request ID:
Crash signature:

Description

OSDs are not created after applying the following spec:

service_type: osd
service_id: dg1
host_pattern: '*'
data_devices:
  rotational: true

Logs:

2020-05-15T04:12:06.289+0000 7f8419a59700  0 [cephadm DEBUG root] Applying service osd.dg1 spec
2020-05-15T04:12:06.289+0000 7f8419a59700  0 [cephadm DEBUG cephadm.schedule] All hosts: [HostPlacementSpec(hostname='mgr0', network='', name=''), HostPlacementSpec(hostname='osd0', network
='', name='')]
2020-05-15T04:12:06.289+0000 7f84232ec700 20 mgr Gil Switched to new thread state 0x5650be3c8480
2020-05-15T04:12:06.289+0000 7f84232ec700 20 mgr ~Gil Destroying new thread state 0x5650be3c8480
2020-05-15T04:12:06.289+0000 7f8419a59700 20 mgr get_config  key: mgr/dashboard/GRAFANA_API_URL
2020-05-15T04:12:06.289+0000 7f84232ec700 20 mgr Gil Switched to new thread state 0x5650be3c8480
2020-05-15T04:12:06.289+0000 7f84232ec700 20 mgr ~Gil Destroying new thread state 0x5650be3c8480
2020-05-15T04:12:06.289+0000 7f8419a59700 10 mgr get_typed_config  GRAFANA_API_URL not found 
2020-05-15T04:12:06.289+0000 7f8419a59700  0 [cephadm DEBUG root] Sleeping for 600 seconds

It might be caused by changes in https://github.com/ceph/ceph/pull/35022

History

#1 Updated by Sebastian Wagner about 2 months ago

  • Status changed from New to In Progress

#2 Updated by Sebastian Wagner about 2 months ago

  • Status changed from In Progress to Pending Backport
  • Priority changed from Normal to Urgent
  • Pull request ID set to 35087

#3 Updated by Sebastian Wagner about 2 months ago

  • Status changed from Pending Backport to Fix Under Review

#4 Updated by Sebastian Wagner about 1 month ago

  • Status changed from Fix Under Review to Pending Backport

#5 Updated by Sebastian Wagner about 1 month ago

  • Status changed from Pending Backport to Resolved
  • Target version set to v15.2.4

Also available in: Atom PDF