Project

General

Profile

Bug #45534

cephadm: "exec: \"--\": executable file not found in $PATH"

Added by Sebastian Wagner 5 months ago. Updated 5 months ago.

Status:
Closed
Priority:
Normal
Assignee:
-
Category:
cephadm (binary)
Target version:
-
% Done:

0%

Source:
Q/A
Tags:
Backport:
Regression:
No
Severity:
3 - minor
Reviewed:
Affected Versions:
ceph-qa-suite:
Pull request ID:
Crash signature:

Description

2020-05-05T14:09:33.186 INFO:teuthology.orchestra.run.smithi042:> sudo /home/ubuntu/cephtest/cephadm --image quay.io/ceph-ci/ceph:e2faf9973a60dd23c3b86a979d7d54f8d13b494c shell -c /etc/ceph/ceph.conf -k /etc/ceph/ceph.client.admin.keyring --fsid dab256ae-8ed9-11ea-a068-001a4aab830c -- ceph config set mgr mgr/cephadm/allow_ptrace true
2020-05-05T14:09:33.256 INFO:ceph.mon.a.smithi042.stdout:May 05 14:09:33 smithi042 bash[26152]: cluster 2020-05-05T14:09:32.207205+0000 mon.a (mon.0) 106 : cluster [DBG] mgrmap e13: y(active, since 6s)
2020-05-05T14:09:35.696 INFO:teuthology.orchestra.run.smithi042.stderr:Error: container_linux.go:346: starting container process caused "exec: \"--\": executable file not found in $PATH": OCI runtime command not found error

http://pulpito.ceph.com/swagner-2020-05-05_13:49:30-rados-wip-swagner-testing-2020-05-05-1117-distro-basic-smithi/5024675/

super interesting that this happens now.

History

#1 Updated by Sebastian Wagner 5 months ago

  • Status changed from New to Closed

Also available in: Atom PDF