Project

General

Profile

Bug #45515

mgr/dashboard:ceph-api-nautilus-backend "ImportError: Failed to import _strptime because the import lockis held by another thread."

Added by Laura Paduano 2 months ago. Updated 2 months ago.

Status:
Resolved
Priority:
Normal
Category:
dashboard/qa
Target version:
% Done:

0%

Source:
Q/A
Tags:
Backport:
Regression:
No
Severity:
3 - minor
Reviewed:
Affected Versions:
ceph-qa-suite:
Pull request ID:
Crash signature:

Description

File "/home/jenkins-build/build/workspace/ceph-api-nightly-nautilus-backend/src/pybind/mgr/dashboard/module.py", line 296, in serve
    uri = self.await_configuration()
    File "/home/jenkins-build/build/workspace/ceph-api-nightly-nautilus-backend/src/pybind/mgr/dashboard/module.py", line 198, in await_configuration
    uri = self._configure()
    File "/home/jenkins-build/build/workspace/ceph-api-nightly-nautilus-backend/src/pybind/mgr/dashboard/module.py", line 169, in _configure
     verify_tls_files(cert_fname, pkey_fname)
   File "/home/jenkins-build/build/workspace/ceph-api-nightly-nautilus-backend/src/pybind/mgr/mgr_util.py", line 156, in verify_tls_files
     verify_cacrt(cert_fname)
   File "/home/jenkins-build/build/workspace/ceph-api-nightly-nautilus-backend/src/pybind/mgr/mgr_util.py", line 129, in verify_cacrt
     if x509.has_expired():
   File "/usr/lib/python2.7/dist-packages/OpenSSL/crypto.py", line 1357, in has_expired
     not_after = datetime.datetime.strptime(time_string, "%Y%m%d%H%M%SZ")
 ImportError: Failed to import _strptime because the import lockis held by another thread.

Jenkins log:

2020-05-09 03:12:39.692 7f4e68e9e700 20 mgr ~Gil Destroying new thread state 0x55b102566840
2020-05-09 03:12:40.316 7f4e7497f700 10 mgr tick tick
2020-05-09 03:12:40.316 7f4e7497f700  4 mgr send_beacon active
2020-05-09 03:12:40.316 7f4e7497f700 10 mgr send_beacon sending beacon as gid 10583
2020-05-09 03:12:40.320 7f4e7497f700 10 monclient: _send_mon_message to mon.a at v2:172.21.1.44:40747/0
2020-05-09 03:12:40.320 7f4e7497f700  1 -- 172.21.1.44:0/14753 --> [v2:172.21.1.44:40747/0,v1:172.21.1.44:40748/0] -- mgrbeacon mgr.x(f4eb0fcf-b744-4f07-9a12-128f6d214f52,10583, [v2:172.21.1.44:6800/14753,v1:172.21.1.44:6801/14753], 1) v8 -- 0x55b10257f700 con 0x55b0fcf33200
2020-05-09 03:12:40.444 7f4e6769b700 10 mgr.server tick 
2020-05-09 03:12:40.444 7f4e6769b700 10 mgr update_delta_stats  v4
2020-05-09 03:12:40.444 7f4e6769b700 10 mgr.server operator() 176 pgs: 176 active+clean; 28 KiB data, 4.0 GiB used, 396 GiB / 404 GiB avail
2020-05-09 03:12:40.444 7f4e6769b700 10 mgr.server operator() 1 health checks
2020-05-09 03:12:40.444 7f4e6769b700 20 mgr.server operator() health checks:
{
    "MGR_MODULE_ERROR": {
        "severity": "HEALTH_ERR",
        "summary": {
            "message": "Module 'dashboard' has failed: Failed to import _strptime because the import lockis held by another thread." 
        },
        "detail": [
            {
                "message": "Module 'dashboard' has failed: Failed to import _strptime because the import lockis held by another thread." 
            }
        ]
    }
}

2020-05-09 03:12:40.444 7f4e6769b700  0 log_channel(cluster) log [DBG] : pgmap v4: 176 pgs: 176 active+clean; 28 KiB data, 4.0 GiB used, 396 GiB / 404 GiB avail
2020-05-09 03:12:40.444 7f4e6769b700 20 mgr.server send_report  + osd,0 SLOW_OPS(0|(0,0))
2020-05-09 03:12:40.444 7f4e6769b700 20 mgr.server send_report  + osd,0 PENDING_CREATING_PGS(0|(0,0))
2020-05-09 03:12:40.444 7f4e6769b700 10 monclient: _send_mon_message to mon.a at v2:172.21.1.44:40747/0
2020-05-09 03:12:40.444 7f4e6769b700  1 -- 172.21.1.44:0/14753 --> [v2:172.21.1.44:40747/0,v1:172.21.1.44:40748/0] -- monmgrreport(1 checks, 0 progress events) v2 -- 0x55b1025a6800 con 0x55b0fcf33200

See recent builds:
- https://jenkins.ceph.com/view/all/job/ceph-api-nightly-nautilus-backend/159
- https://jenkins.ceph.com/view/all/job/ceph-api-nightly-nautilus-backend/160
- https://jenkins.ceph.com/view/all/job/ceph-api-nightly-nautilus-backend/161


Related issues

Related to mgr - Bug #41879: Dashboard yields "ImportError: Failed to import _strptime because the import lockis held by another thread." after update to 14.2.4 New 09/17/2019
Related to mgr - Bug #39979: ceph device check-health: Error EIO: Module 'devicehealth' has experienced an error and cannot handle commands: Failed to import _strptime because the import lockis held by another thread. New 05/20/2019

History

#1 Updated by Laura Paduano 2 months ago

  • Related to Bug #41879: Dashboard yields "ImportError: Failed to import _strptime because the import lockis held by another thread." after update to 14.2.4 added

#2 Updated by Alfonso Martínez 2 months ago

  • Status changed from New to Fix Under Review
  • Assignee set to Alfonso Martínez
  • Pull request ID set to 35016

#4 Updated by Volker Theile 2 months ago

  • Related to Bug #39979: ceph device check-health: Error EIO: Module 'devicehealth' has experienced an error and cannot handle commands: Failed to import _strptime because the import lockis held by another thread. added

#5 Updated by Alfonso Martínez 2 months ago

  • Status changed from Fix Under Review to Resolved

#6 Updated by Lenz Grimmer 2 months ago

  • Target version set to v14.2.10

Also available in: Atom PDF