Project

General

Profile

Bug #45508

mgr/dashboard: cropped actions menu in nested details

Added by Ernesto Puerta 9 months ago. Updated 7 months ago.

Status:
Resolved
Priority:
High
Assignee:
Category:
dashboard/rbd
Target version:
% Done:

0%

Source:
Community (dev)
Tags:
Backport:
octopus
Regression:
No
Severity:
2 - major
Reviewed:
Affected Versions:
ceph-qa-suite:
Pull request ID:
Crash signature:

Description

cropped_menu.png View (34.7 KB) Ernesto Puerta, 05/11/2020 04:31 PM


Related issues

Related to mgr - Fix #47008: mgr/dashboard: restore table footer row size Resolved
Copied to mgr - Backport #46048: octopus: mgr/dashboard: cropped actions menu in nested details Resolved

History

#1 Updated by Ernesto Puerta 9 months ago

  • Priority changed from Normal to High
  • Severity changed from 3 - minor to 2 - major

Increased severity/priority as it hides "Delete snapshot" action, making it impossible to delete a snapshot.

#2 Updated by Avan Thakkar 8 months ago

  • Assignee set to Avan Thakkar

#3 Updated by Lenz Grimmer 8 months ago

  • Tags set to usability

#4 Updated by Avan Thakkar 8 months ago

  • Status changed from New to Fix Under Review

#5 Updated by Lenz Grimmer 7 months ago

  • Status changed from Fix Under Review to Pending Backport
  • Pull request ID set to 35295

#6 Updated by Avan Thakkar 7 months ago

  • Copied to Backport #46048: octopus: mgr/dashboard: cropped actions menu in nested details added

#7 Updated by Avan Thakkar 7 months ago

I am not sure if we should backport it to octopus, because it doesn't face this issue for now . but I have already created backport to octopus for this issue. Should I close https://github.com/ceph/ceph/pull/35620 ?

#8 Updated by Avan Thakkar 7 months ago

  • Backport deleted (octopus)

#9 Updated by Avan Thakkar 7 months ago

  • Copied to deleted (Backport #46048: octopus: mgr/dashboard: cropped actions menu in nested details)

#10 Updated by Nathan Cutler 7 months ago

  • Backport set to octopus

#11 Updated by Nathan Cutler 7 months ago

  • Copied to Backport #46048: octopus: mgr/dashboard: cropped actions menu in nested details added

#12 Updated by Nathan Cutler 7 months ago

  • Status changed from Pending Backport to Resolved

#13 Updated by Avan Thakkar 7 months ago

The issue is now reproducible in octopus(15.2.4) branch, so will create backport to this branch. It was not reproducible before as in previous version of octopus there was no ".datatable-row-detail " class

#14 Updated by Avan Thakkar 7 months ago

  • Status changed from Resolved to Pending Backport

#15 Updated by Avan Thakkar 7 months ago

  • Copied to deleted (Backport #46048: octopus: mgr/dashboard: cropped actions menu in nested details)

#16 Updated by Avan Thakkar 7 months ago

  • Related to Backport #46048: octopus: mgr/dashboard: cropped actions menu in nested details added

#18 Updated by Lenz Grimmer 7 months ago

  • Status changed from Pending Backport to Resolved

#19 Updated by Nathan Cutler 7 months ago

  • Related to deleted (Backport #46048: octopus: mgr/dashboard: cropped actions menu in nested details)

#20 Updated by Nathan Cutler 7 months ago

  • Copied to Backport #46048: octopus: mgr/dashboard: cropped actions menu in nested details added

#21 Updated by Alfonso Martínez 5 months ago

  • Related to Fix #47008: mgr/dashboard: restore table footer row size added

Also available in: Atom PDF