Project

General

Profile

Bug #45396

ceph-fuse: building the source code failed with libfuse3.5 or higher versions

Added by Xiubo Li 5 months ago. Updated 3 months ago.

Status:
Resolved
Priority:
Normal
Assignee:
Category:
-
Target version:
% Done:

0%

Source:
Development
Tags:
Backport:
octopus
Regression:
No
Severity:
3 - minor
Reviewed:
Affected Versions:
ceph-qa-suite:
Component(FS):
ceph-fuse
Labels (FS):
Pull request ID:
Crash signature:

Related issues

Related to fs - Bug #45866: ceph-fuse build failure against libfuse v3.9.1 Resolved
Copied to fs - Backport #45845: octopus: ceph-fuse: building the source code failed with libfuse3.5 or higher versions Resolved

History

#1 Updated by Xiubo Li 5 months ago

  • Status changed from New to In Progress

#2 Updated by Xiubo Li 5 months ago

  • Project changed from sepia to Ceph
  • Pull request ID set to 34719

#3 Updated by Xiubo Li 5 months ago

  • Project changed from Ceph to fs
  • Component(FS) libcephfs added

#4 Updated by Xiubo Li 5 months ago

The 'int cmd' parameter type in fuse ioctl changed to 'unsigned int' since libfuse3.5.0.

#5 Updated by Xiubo Li 5 months ago

  • Status changed from In Progress to Fix Under Review

#6 Updated by Patrick Donnelly 5 months ago

  • Target version set to v16.0.0
  • Source set to Development
  • Backport set to octopus
  • ceph-qa-suite deleted (fs)

#7 Updated by Patrick Donnelly 4 months ago

  • Status changed from Fix Under Review to Pending Backport
  • Component(FS) ceph-fuse added
  • Component(FS) deleted (libcephfs)

#8 Updated by Nathan Cutler 4 months ago

  • Copied to Backport #45845: octopus: ceph-fuse: building the source code failed with libfuse3.5 or higher versions added

#9 Updated by Patrick Donnelly 4 months ago

  • Related to Bug #45866: ceph-fuse build failure against libfuse v3.9.1 added

#10 Updated by Nathan Cutler 3 months ago

  • Status changed from Pending Backport to Resolved

While running with --resolve-parent, the script "backport-create-issue" noticed that all backports of this issue are in status "Resolved" or "Rejected".

Also available in: Atom PDF