Project

General

Profile

Bug #45332

qa: TestExports is failure under new Python3 runtime

Added by Sidharth Anupkrishnan 2 months ago. Updated 20 days ago.

Status:
Resolved
Priority:
Normal
Category:
-
Target version:
% Done:

0%

Source:
Development
Tags:
Backport:
octopus,nautilus
Regression:
No
Severity:
3 - minor
Reviewed:
Affected Versions:
ceph-qa-suite:
Component(FS):
cephfs.pyx, qa-suite
Labels (FS):
qa
Pull request ID:
Crash signature:

Description

In http://qa-proxy.ceph.com/teuthology/sidharthanup-2020-04-28_19:54:15-multimds-master-distro-default-smithi/4995153/teuthology.log , we get failure due to this error:

`AttributeError: 'str' object has no attribute 'stdout'`

This is due to a 'str' object being used rather that an StringIO object since in the new Python3 runtime changes sh() returns a string. This error is caused after these commits were introduced : https://github.com/ceph/teuthology/commit/6242d9f649a66e8f0a9d8b3964e10d84fbfd6aad and https://github.com/ceph/teuthology/commit/6242d9f649a66e8f0a9d8b3964e10d84fbfd6aad


Related issues

Copied to fs - Backport #45967: nautilus: qa: TestExports is failure under new Python3 runtime Resolved
Copied to fs - Backport #46011: octopus: qa: TestExports is failure under new Python3 runtime Resolved

History

#1 Updated by Sidharth Anupkrishnan 2 months ago

  • Pull request ID set to 34834

#2 Updated by Patrick Donnelly about 2 months ago

  • Status changed from New to Resolved
  • Target version set to v16.0.0
  • Source set to Development
  • Component(FS) cephfs.pyx added

#3 Updated by Ramana Raja 30 days ago

  • Status changed from Resolved to Pending Backport
  • Backport set to octopus,nautilus

#4 Updated by Ramana Raja 30 days ago

  • Copied to Backport #45967: nautilus: qa: TestExports is failure under new Python3 runtime added

#5 Updated by Nathan Cutler 24 days ago

  • Copied to Backport #46011: octopus: qa: TestExports is failure under new Python3 runtime added

#6 Updated by Nathan Cutler 20 days ago

  • Status changed from Pending Backport to Resolved

While running with --resolve-parent, the script "backport-create-issue" noticed that all backports of this issue are in status "Resolved" or "Rejected".

Also available in: Atom PDF