Project

General

Profile

Feature #453

osd: return error (instead of blocking) on lost objects

Added by Sage Weil about 10 years ago. Updated almost 10 years ago.

Status:
Resolved
Priority:
Normal
Assignee:
Category:
OSD
Target version:
% Done:

0%

Source:
Tags:
Backport:
Reviewed:
Affected Versions:
Pull request ID:

Description

We now track unfound objects. If we decide those objects are truly lost, we need to return errors when trying to read them.

We may also want to record their LOST status on disk in placeholder objects so that we can allow last_complete to move forward. Otherwise their unfound/lost state is tied to the missing/unfound sets, and incurs permanent peering/recovery overhead going forward.


Related issues

Related to Ceph - Bug #428: osd: recovery stalls on mismatched snapset and object Resolved 09/23/2010
Related to Ceph - Bug #491: osd: pg incorrectly going active Can't reproduce 10/14/2010
Related to Ceph - Bug #492: osd: do not remove divergent objects Rejected 10/14/2010
Related to Ceph - Feature #526: osd: unfound objects rework Resolved 10/29/2010
Follows Ceph - Bug #503: osd: query osds since last_epoch_clean before concluding objects lost? Closed 10/18/2010

History

#1 Updated by Sage Weil about 10 years ago

  • Assignee set to Colin McCabe

#2 Updated by Sage Weil about 10 years ago

  • Target version changed from v0.23 to v0.24

#3 Updated by Sage Weil almost 10 years ago

  • Estimated time set to 4.00 h
  • Source set to 3

#4 Updated by Sage Weil almost 10 years ago

  • Subject changed from osd: handle LOST_REVERT to osd: return error (instead of blocking) on lost objects

#5 Updated by Colin McCabe almost 10 years ago

  • Status changed from New to Resolved

It's passing the lost1 and lost2 unit tests now.

#6 Updated by Sage Weil almost 10 years ago

  • translation missing: en.field_position deleted (374)
  • translation missing: en.field_position set to 339

#7 Updated by Sage Weil almost 10 years ago

  • translation missing: en.field_position deleted (339)
  • translation missing: en.field_position set to 301

Also available in: Atom PDF