Project

General

Profile

Bug #45284

cephadm: Access host files on "cephadm shell"

Added by Ricardo Marques 5 months ago. Updated 4 months ago.

Status:
Resolved
Priority:
Normal
Category:
cephadm (binary)
Target version:
% Done:

0%

Source:
Tags:
Backport:
octopus
Regression:
No
Severity:
3 - minor
Reviewed:
Affected Versions:
ceph-qa-suite:
Pull request ID:
Crash signature:

Description

I have a file on my host, that I would like to use to set a "config-key":

master:/etc/ceph # head -1 /tmp/ceph-salt-ssh-id_rsa
-----BEGIN RSA PRIVATE KEY-----

But when I try to use that file, I get an error because the file is not accessible inside the container:

master:/etc/ceph # cephadm shell -- ceph config-key set mgr/cephadm/ssh_identity_key -i /tmp/ceph-salt-ssh-id_rsa
...
Can't open input file /tmp/ceph-salt-ssh-id_rsa: [Errno 2] No such file or directory: '/tmp/ceph-salt-ssh-id_rsa'

History

#1 Updated by Ricardo Marques 5 months ago

  • Assignee set to Ricardo Marques

#2 Updated by Ricardo Marques 5 months ago

  • Status changed from New to In Progress

#3 Updated by Ricardo Marques 5 months ago

  • Pull request ID set to 34773

#4 Updated by Sebastian Wagner 5 months ago

  • Status changed from In Progress to Pending Backport

#5 Updated by Sebastian Wagner 4 months ago

  • Status changed from Pending Backport to Resolved
  • Target version changed from v16.0.0 to v15.2.4

Also available in: Atom PDF